Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I upgraded to 12.10 from 12.04. I have removed the old kernel 3.2.21 in 12.04.

On start up, I get an error before login, such as vmware ....

In 12.04, I have installed VMware 9.0 and now in 12.10, when I open VMware workstation to start a virtual machine, my monitor turns to black and I must logout and login again.

How do I fix it? Is related to VMware and kernel or not?

share|improve this question
add comment

2 Answers

EDIT: This problem may not be related to 12.10, bur rather to 3.5/3.6 kernels (I'm using mainline 3.6.2, because I understand it has better support for my ATI video card...)

The problem seems to be VMWare side, rather than ubuntu side.

I have successfully solved this problem by applying the patch found here (direct download link: vmware9_kernel35_patch.tar.bz2). The patched is for kernel 3.5, but I'm using 3.6 and it still fixed my problem. Note, the patch's name indicates it's for Workstation 9, but it is also for Player 5.0.0

Uninstalling

Some people in the thread linked above suggest uninstalling BEFORE upgrading to 12.10. My exact process was somewhat convoluted and may be a bit of an exception, so I am unclear if you need to uninstall or not. It may work installed the patch after upgrading. Should you want to, here are the instructions:

sudo vmware-installer -u vmware-player
sudo rm  /usr/lib/vmware/modules/source/.patched

or a much more involved uninstall like this:

sudo -i

/usr/bin/vmware-installer -u vmware-workstation

/etc/init.d/vmware stop
lsmod | grep vm

cd /lib/modules/kernel_version/miscmv vm* /tmp

rmmod vmnet.o
rmmod vmmon.o
rmmod vmci.o
rmmod vmblock.o
rmmod vmppuser.o

rm /etc/rc.d/init.d/rc2.d/*vmware*
rm /etc/rc.d/init.d/rc3.d/*vmware*
rm /etc/rc.d/init.d/rc5.d/*vmware*
rm /etc/rc.d/init.d/rc6.d/*vmware*

rm -rf /etc/vmware*
rm /usr/bin/vmware-usbarbitrator
rm /usr/bin/vmnet*
rm -r /usr/lib/vmware*
rm -r /usr/share/doc/vmware*
rm -fr /var/run/vm*`

Applying the Patch

The zip contains a .sh script. Run it. Very simple.

  • For me, the patch didn't properly detect my VMPlayer 5 version (perhaps due to a botched uninstall, careful copying and pasting the contents of the uninstall process above and pasting it into the console... like I said, my process was convoluted), so commented the error text, applied the patch, and it worked.
share|improve this answer
add comment

Looks like you need to install the Ubuntu kernel header package looking at the logs it generates.

try the command below:

sudo apt-get install linux-headers-$(uname -r)

and then restart the installation process.

Let me know how you got on.

Worked for me VMWare ver 9

share|improve this answer
add comment

protected by Community Jan 11 '13 at 12:27

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.