Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After I upgraded to Quantal, evolution asked to create a new identity (as if the previous config and prefs were vanished). When creating the calendar, it can't establish a connection with the server, and if I try to retrieve the calendars I receive an "http error: method not allowed"...

Please help!

share|improve this question

3 Answers 3

I can reproduce this issue on 12.10 as well (getting the HTTP Error: Not Found message when clicking on 'Find Calendars').

All I have is a workaround. You can delete your previously created calendar and create a new one. When you do this (selecting Type 'Google' and the primary Google account email address in 'User'), when you click on the Calendar drop down box, you should be able to enter your password and be presented with the calendar list from Google as you would expect.

I'm not sure why this doesn't work in the other screen (or Properties screen), but it works in the new account screen for me.

share|improve this answer

I had similar issues when upgrading evolution. It lost all my configurations for all accounts (see info on the bug below). Then when I went to set it up again it took me a while for all 6 or 7 of the calendars to get set up. It kept seeming to hand when identifying so I was only able to add 2 at a time (add 2, restart evolution, add another 2, etc). I'm still not certain that all my files are sync'd to disk as I like so contemplating a purge and starting over still. I should also mention I did not already have the associated google account set up in the online accounts setting.

In researching my issues I found a bug - https://bugs.launchpad.net/ubuntu/+source/evolution/+bug/1049028 I know it's not explicitly related but could be. It says there's a fix released so hopefully this goes away shortly, if this is indeed the issue you're facing.

share|improve this answer
up vote 0 down vote accepted

My answer is not so different from Mar Warne's one. After a couple of reboots, my Personal Keyring started asking for google password, I could not say if because of Evolution, Web Accounts, or a Webapps related thing.

In any case, I tried with my google account password, but the dialog window continued to show up. Then I remembered I created a password for third party apps (2-step verication needed), and even if I disabled 2-step, some of my apps, such as Thunderbird or calendar clients still asks for the second password, don't know why.

So I tried this second one, and Evolution opened, showing my calendar multiple times (each time I created it, I suppose).

Just deleted the copies and all started to work again.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.