Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a laptop with ATI Radeon 6770M HD Hybrid graphics card. In Ubuntu 12.04, I installed the fglrx driver through "additional drivers" and it worked. (I can even switch GPUs). But in the new Ubuntu 12.10, after installing, Unity won't load.

Only the mouse and the wallpaper. If I initialize the settings sudo aticonfig --initial then after rebooting it gives a warning saying I'm in low graphics mode! How to fix this?

Earlier I used software source to install the drivers. But when using the terminal, I got this warning :

update-alternatives: warning: forcing reinstallation of alternative /usr/lib/fglrx/ld.so.conf because link group x86_64-linux-gnu_gl_conf is broken

Update : Filed a bug report in launchpad : https://bugs.launchpad.net/fglrx/+bug/1068661

share|improve this question
    
Just filed a bug report : bugs.launchpad.net/fglrx/+bug/1068661 –  EApubs Oct 19 '12 at 14:23
2  
I believe this issue is because the ATI drivers do not yet support the current X Server 1.13. So we are going to be waiting on ATI. –  Phil Hannent Oct 19 '12 at 16:11
1  
I've just added my comments to that bug report. I find it somewhat shocking that a bug like this made it through to final, as ATI cards are not that rare... –  CadentOrange Oct 21 '12 at 11:16
1  
AMD released a special 12.9 beta driver that would work with the xserver 1.13 in 12.10: support.amd.com/us/kbarticles/Pages/…; however, this doesn't seem to have been packaged into the default repository yet. Also, it only supports HD 5000 or later cards: askubuntu.com/questions/203232/… –  Andrew Mao Oct 21 '12 at 20:19
1  
Guys, please add this information in either answers or add it to existing answers, information should be posted there, not buried in comments! –  Jorge Castro Nov 10 '12 at 13:50
show 4 more comments

8 Answers 8

I went to terminal (Ctrl+Alt+F1 for example) and did :

sudo apt-get remove fglrx

Now my computer is pretty slow but a least I can use it and wait for the problem to be fixed.

share|improve this answer
add comment

I found the problem. On upgrade of Ubuntu 12.04 -> Ubuntu 12.10, the contents of lightdm.conf in /etc/lightdm/ are completely erased. Installing or reconfiguring lightdm does NOT install this file here, so lightdm does not know how to go about displaying itself. You must do the following:

sudo apt-get purge fglrx lightdm && sudo apt-get install lightdm ubuntu-desktop && sudo nano /etc/lightdm/lightdm.conf

insert the following text:

[SeatDefaults]
user-session=ubuntu
greeter-session=unity-greeter
allow-guest=false

Save the file via CTRL + X and sudo reboot. You may not have to uninstall fglrx, but I do not know.

share|improve this answer
1  
can you please tell us the steps you followed? Installed fglrx from the additional drivers and installed gdm? –  EApubs Oct 19 '12 at 7:51
    
sudo apt-get purge fglrx lightdm && sudo apt-get install lightdm ubuntu-desktop && revised contents above on how to configure lightdm. –  mmstick Oct 19 '12 at 7:58
    
one small problem... just recognized that you have updated from ubuntu 12.04. Im on a new installation –  EApubs Oct 19 '12 at 8:04
add comment

I started with a clean 12.10 install (not an upgrade) My card is a Radeon HD 5450

First thing I done was to install Linux-source and Linux headers

sudo apt-get install linux-source
sudo apt-get install linux-headers-generic

I noticed that many with Nvidia cards were having to do this and am sure I saw mentioned some-where that it also helped ATI users.

Like everyone else if I installed either of the proprietary drivers after reboot I was able to login but lost unity.

One thing I did notice is that installing the driver did not install Catalyst control centre (not sure if it is the same for everyone else)

So I installed Synaptic package manager and installed fglrx-updates from there

enter image description here

Now the Catalyst control centre was installed.

Upon rebooting however instead of being able to login with no Unity the system was hanging at the splash screen.

So I applied nomodeset and this time it booted with Unity present

Here is the result of fglrxinfo

enter image description here

And here is what software sources says

enter image description here

With nomodeset applied I might not be getting the splash screen on boot up but fglrx-updates is working well. I would go as far as to say that it is performing better than it was in 12.04

More info

Grub offers me 2 kernels

3.5.0-18-generic and 3.5.0-17-generic

The later one '18' is good, the older one '17' still loads without Unity

share|improve this answer
3  
On a just-installed Ubuntu 12.10 I installed linux-headers-generic, fgrlx-updates and fgrlx-amdcccle-updates then restarted and the driver (including Catalyst Control Center) have been installed. I didn't nomodeset, but unlike you, I didn't try to install the proprietary driver before. –  Zippoxer Oct 24 '12 at 12:26
    
@Zippoxer perhaps you could add this information to this bug report bugs.launchpad.net/fglrx/+bug/1068661 It may help others and help get the bug sorted quicker. –  Chris Carter Oct 24 '12 at 18:50
1  
Can't apply 'nomodeset' or it doesn't help. I've added nomodeset to boot by this instruction ubuntuforums.org/showthread.php?t=1613132 but still getting hanged splash screen. How to fix it? –  megas Nov 29 '12 at 15:02
    
This has worked for me on an HD5450. I previously tried so many other guides without success. I had linux-source and linux-headers-generic already installed so I didn't have to this time. I followed your instructions and everything is working perfectly. However, I didn't have to do apply monodeset. Thanks very much! –  Jean-Louis Apr 6 '13 at 13:13
    
@Jean-Louis nomodeset, not monodeset. Sadly, I've tried this advice but even with nomodeset my unity is gone and my terminal doesn't work. Messed up. –  raindrop Aug 16 '13 at 22:58
add comment

I got the same problem. May i found a possible solution. First i opened the Ubuntu-Software-Center and i was looking for "additional drivers". After installing the "additional drivers" i installed the ATI driver and after a reboot my notebook startet normally with unity and with the right propietary driver.

Note: The installation from the Software-Sources-button was not working in my case.

share|improve this answer
1  
That would fit in with my solution, could there be something wrong with with the package offered in software sources? –  Chris Carter Oct 22 '12 at 16:37
    
Didn't worked for me :( –  EApubs Oct 23 '12 at 16:38
add comment

This works for me.

    sudo apt-get install linux-headers-generic

Go to amd.com and download their latest beta driver (which was just updated to 12.11). Run and install.

Please note that the stable driver will not work with unity.

Then head here to get a script to remove the watermark: http://areyoueye.net/?p=187

Slainte!

share|improve this answer
    
Hi @ryanpcmcquen do you have a pure AMD/ATI graphics card or do you have an Intel one working as the integrated besides the AMD/ATI discrete. I'm finding that for those with only AMD/ATI cards your solution with the new AMD Catalyst 12.11 drivers does work, but for those with an added Intel integrated card this doesn't provide the solution. –  davorao Oct 25 '12 at 6:02
    
I have the A8, so no Intel. –  ryanpcmcquen Nov 7 '12 at 18:47
1  
This worked for me with the Radeon HD 5670. –  thelastshadow Dec 9 '12 at 23:26
    
Using the beta driver was the only solution that actually worked on my system, also using a single Radeon HD card. –  Bruno Pereira Dec 25 '12 at 23:18
add comment

There is an open bug at this time with fglrx-installer and Ubuntu 12.10

https://bugs.launchpad.net/ubuntu/+source/fglrx-installer/+bug/1025488

I always say "search for open and confirmed bugs" before you proceed with something, especially when the distribution is new released.

You can participate to this bug if affects you ,by posting comments there and click the button "Yes it affects me" (you have to have a Launchpad account).

share|improve this answer
add comment

For those who have hybrid systems (ATI/intel) and fglrx has stopped working in 12.10, then the problem might be like the one described here (fglrx incompatibility with the recent version of the intel driver): https://bugs.launchpad.net/ubuntu/+source/fglrx-installer-updates/+bug/1068404

What I would suggest would be

  1. Remove all the fglrx* packages:

    sudo apt-get purge fglrx*
    
  2. Add my PPA in your repositories list:

    sudo add-apt-repository ppa:andrikos

  3. Update your package information:

    sudo apt-get update 
    
  4. Update the fglrx and intel drivers:

    sudo apt-get install fglrx xserver-xorg-video-intel
    
  5. Don't forget to enable the fglrx driver

    sudo aticonfig --initial --force
    
share|improve this answer
    
Hi Nick, I tried your solution by unfortunately it didn't work out for me. Also i am wondering if the command under 4. should be sudo aticonfig --initial? I also could not find the command under the aticonfig man pages; see man.cx/aticonfig(1) –  davorao Oct 28 '12 at 14:09
    
Yes davorao, it is initial, I'm fixing it now. What system do you have? This solution is for the hybrid ATI/intel under ubuntu 12.10 –  Nick Andrik Oct 29 '12 at 15:37
    
Hi Nick, my system is a Intel HD3000 acting as the integrated GPU with a Radeon HD 6490M as the discrete GPU. The Laptop in question is the Samsung Chronos 7 700z3a-S03-DE. I have tried the using the xserver-xorg-video-intel deb from your PPA but couldn't manage to get it working. –  davorao Nov 2 '12 at 11:14
    
I tried this solution. It worked. But I have nasty "AMD testing only" box and (not sure if connected, but very probable) my mouse hangs sometimes and sometimes also with keyboards - especially when selecting something in unity bar. Do you think it's connected? More stable solution would be better! –  greg606 Nov 2 '12 at 14:39
    
I would believe this is another bug. If my solution worked for you, could you please vote it up so that more people see it? Thanks –  Nick Andrik Nov 3 '12 at 15:51
show 6 more comments

Solution for me:

  1. remove current fglrx sudo sh /usr/share/ati/fglrx-uninstall.sh sudo apt-get remove --purge fglrx*

  2. add ppa repository sudo apt-add-repository ppa:andrikos/ppa

  3. update packages list sudo apt-get update

  4. install packages sudo apt-get install fglrx-updates

share|improve this answer
add comment

protected by Community Oct 21 '12 at 21:45

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.