Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to connect to a remote server in cloud hosting service using remote desktop client application. Actually, the remote server is a server edition. I need it as GUI enabled like an Ubuntu desktop edition so that it will be user friendly. So I have installed Ubuntu-desktop using sudo apt-get install ubuntu-desktop.

I'm able to connect to the server via putty SSH client. In putty we can run in command line mode only. I want to run the server in GUI mode. I can't access the server as GUI enabled in remote desktop client. Mine is Ubuntu 12.04 LTS. The remote server is also Ubuntu 12.04 LTS.

What shall I do now?

share|improve this question
add comment

1 Answer 1

NX Free Edition for Linux

An enterprise-class multi-platform solution for remote access and virtual desktop delivery.

http://www.nomachine.com/select-package.php?os=linux&id=1

DEB version

Download the DEBs

Change your working directory to the location where you saved the package and install it by running from a console:

  $ sudo dpkg -i nxclient_3.5.0-7_i386.deb
  $ sudo dpkg -i nxnode_3.5.0-9_i386.deb
  $ sudo dpkg -i nxserver_3.5.0-11_i386.deb

If you don't have the sudo utility installed, log on as superuser ("root") and run the commands without sudo.

Note: click here for detailed instructions on how to install the NX Client, NX Node and NX Server packages. The NX service can be controlled by the command

/usr/NX/bin/nxserver --status|--start|--stop|--restart.

Additional commands are available to configure the server. Try

/usr/NX/bin/nxserver --help

for more information.

Please, don't forget to download and read the NX Server Administrator's Guide available here.

share|improve this answer
    
Thank you, Your suggestion was realy helpful. I've installed NX client,Server,Node in the remote server and installed NX client in the client side.Then i tried to configure the NX Server.When i run ./nxserver --status,it has to show the status as running.But it shows nothing.I tried to add a new user also using command sudo ./nxserver --useradd username --administrator and Now it has ask for password but it didn't.Whenever I use ./nxserver --(option) ,there is no effect for it. What is the cause for this problem? What shall i do now? Please help.. Thanks –  NagaLakshmi Oct 20 '12 at 4:50
    
As i remember (having a long time to use nx) you have nothing to configure to NX server. Just go to the client side and run NX client to connect to remote server (running NX Server) with its ip and port 22, with the user name and password of the remote server. –  ptheo Oct 20 '12 at 9:59
    
Hi.. When i try to open NX client wizard,it is showing nxclient: cannot connect to X server what shall i do now? Thanks in advance........ –  NagaLakshmi Oct 20 '12 at 10:31
    
You may have not start the NX server service after installing. See my answer edited. –  ptheo Oct 20 '12 at 11:23
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.