Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I download something to my desktop, or insert a CD or flash drive, the icon appears on my desktop. When I have conky running, the icon sometimes appears in the top right corner, underneath conky; where I can't see it.

How do I stop this happening?

My .conkyrc is pasted below. I didn't write it all myself, so I'm not entirely sure what I need to change, or what parts are relevant for this particular question...

# UBUNTU-CONKY
# A comprehensive conky script, configured for use on
# Ubuntu / Debian Gnome, without the need for any external scripts.
#
# Based on conky-jc and the default .conkyrc.
# INCLUDES:
# - tail of /var/log/messages
# - netstat shows number of connections from your computer and application/PID making it. Kill spyware!
#
# -- Pengo
# 

# Create own window instead of using desktop (required in nautilus)
own_window yes
own_window_type override
own_window_transparent yes
own_window_hints undecorated,below,sticky,skip_taskbar,skip_pager

# Use double buffering (reduces flicker, may not work for everyone)
double_buffer yes

# fiddle with window
use_spacer right

# Use Xft?
use_xft yes
xftfont DejaVu Sans:size=8
xftalpha 0.8
text_buffer_size 2048

# Update interval in seconds
update_interval 3.0

# Minimum size of text area
# minimum_size 250 5

# Draw shades?
draw_shades no

# Text stuff
draw_outline no # amplifies text if yes
draw_borders no
uppercase no # set to yes if you want all text to be in uppercase

# Stippled borders?
stippled_borders 3

# border margins
border_margin 9

# border width
border_width 10

# Default colors and also border colors, grey90 == #e5e5e5
default_color grey

own_window_colour brown
own_window_transparent yes

# Text alignment, other possible values are commented
#alignment top_left
alignment top_right
#alignment bottom_left
#alignment bottom_right

# Gap between borders of screen and text
gap_x 10
gap_y 20

# stuff after 'TEXT' will be formatted on screen

TEXT
$color
${color orange}SYSTEM ${hr 2}$color
$nodename $sysname $kernel on $machine

${color orange}CPU ${hr 2}$color
${freq}MHz   Load: ${loadavg}   Temp: ${acpitemp}
$cpubar
${cpugraph 000000 ffffff}

NAME ${goto 150}PID ${goto 200}CPU% ${goto 250}MEM%
${top name 1} ${goto 150}${top pid 1} ${goto 200}${top cpu 1} ${goto 250}${top mem 1}
${top name 2} ${goto 150}${top pid 2} ${goto 200}${top cpu 2} ${goto 250}${top mem 2}
${top name 3} ${goto 150}${top pid 3} ${goto 200}${top cpu 3} ${goto 250}${top mem 3}
${top name 4} ${goto 150}${top pid 4} ${goto 200}${top cpu 4} ${goto 250}${top mem 4}

${color orange}MEMORY / DISK ${hr 2}$color
RAM:   $memperc%   ${membar 6}$color
Swap:  $swapperc%   ${swapbar 6}$color

Home:  ${fs_free_perc /home}%   ${fs_bar 6 /}$color 
Free Space: ${fs_free /home}

${color orange}NETWORK (${addr eth0}) ${hr 2}$color
Down: $color${downspeed eth0} k/s ${alignr}Up: ${upspeed eth0} k/s
${downspeedgraph eth0 25,140 000000 ff0000} ${alignr}${upspeedgraph eth0 
25,140 000000 00ff00}$color
Total: ${totaldown eth0} ${alignr}Total: ${totalup eth0}
${execi 30 netstat -ept | grep ESTAB | awk '{print $9}' | cut -d: -f1 | sort | uniq -c | sort -nr}

${color orange}WIRELESS (${addr wlan0}) ${hr 2}$color
Down: $color${downspeed wlan0} k/s ${alignr}Up: ${upspeed wlan0} k/s
${downspeedgraph wlan0 25,140 000000 ff0000} ${alignr}${upspeedgraph wlan0 
25,140 000000 00ff00}$color
Total: ${totaldown wlan0} ${alignr}Total: ${totalup wlan0}
${execi 30 netstat -ept | grep ESTAB | awk '{print $9}' | cut -d: -f1 | sort | uniq -c | sort -nr}

Conky solutions have been offered, but perhaps these aren't the best way of approaching it. What I really want is to stop icons even appearing in that part of the desktop window: that is, I want to make part of the desktop real estate "off-limits" to new icons appearing on the desktop.

share|improve this question
    
I'm also in the same situation :/ –  Pitto Jan 15 '11 at 22:11
    
As a suggestion, and according to your last edit (last paragraph), I'd say you change the question to something like "How to choose position of auntomount icons" –  luri Jan 27 '11 at 14:00
    
It's not just automount icons: it's stuff I download to the desktop. And it is relevant that it's so as to avoid conky that I want to do this. –  Seamus Jan 27 '11 at 14:17

4 Answers 4

up vote 2 down vote accepted

For Maverick, and assuming Gnome...

sudo apt-get install screenlets

Download Folderview Screenlet and then open Screenlets to install it.

Applications->Accessories->Screenlets

After installation, double-click the "Folder View" screenlet. Right-click on the screenlet and choose Properties. Go to Options->Folder and select Desktop. Click Close.

Now make your Gnome Desktop icons disappear:

[ALT]+[F2]
gconf-editor
Run

Go to apps->nautilus->preferences->show_desktop, setting the value to false. Move your "Folder View" screenlet away from Conky.

You can still access "places" and "devices" from the file manager. In fact, you can do everything with no Desktop icons at all. Just running gconf-editor to disable Desktop icons might work for you, too.

share|improve this answer
    
I can still access places and devices from the file manager, but it's convenient to have them appear on the desktop. –  Seamus Feb 1 '11 at 20:29

You can get what you want if you change these two lines as shown:

 own_window_type panel

 own_window_transparent no

And you add these two:

 own_window_argb_visual yes

 own_window_argb_value 0

Explanation:

own_window_argb_visual yes enables true transparency (own_window_transparent yes means just pseudo-transparency, which just 'clones' background... we have to set this latter to no, that's why we need to edit the second line above)

own_window_argb_value 0 sets 'alpha' to 0 (totally transparent). It can be set up to 255 (totally opaque)

own_window_argb_visual yes won't work with override and that's why it's necesary to change own_window_type to panel

For me it worked flawlesly. The only drawback is that you can see the icon but you can't click it, as it is, still, under conky's window; however, you can select this icon clicking and dragging the mouse -a windowed selection-.... after that, you can bring up context menu with the keyboard or simply press enter to 'open' the media you just inserted.

share|improve this answer
    
I just want to stop the icons appearing in that part of the screen taken up with conky. This is a good intermediate solution, but not ideal. –  Seamus Jan 27 '11 at 11:21
    
Actually, I tried this, and it doesn't work as expected. What happens is that all icons and windows are pushed "under" conky. The conky is top right, and it pushes everything down to under the bottom of the conky window. –  Seamus Jan 27 '11 at 11:47
    
That was what I tried to say in my last paragraph.... they're under conky window. You can see them, and then you can select them by window dragging and then changing their location (moving them). Try this workaround: disable conky for a while, plug the device you want, move its icon wherever it doesn't interfere with conky. When re-plugged, the icons appear in the same position (at least that's working for me). –  luri Jan 27 '11 at 12:47
    
No. What I mean is that all of the desktop space to the left of the conky window is cleared of icons and they are all moved down to the bottom of the window. It also makes maximised windows only appear in the bottom third of the screen. –  Seamus Feb 1 '11 at 20:21

I do not think this is possible. However, depending settings, you should be able to move your Conky by holding you Alt key and use your left mouse button (given that you use right-handed settings) and move it like any other window.

You can also remove icons on desktop altogether in gconf-editor. Just disable /apps/nautilus/preferences/show_desktop and your desktop will be nice and clean.

share|improve this answer
    
Not with own_window_type override that doesn't work, I don't think. –  Seamus Feb 1 '11 at 20:22

Read Conky faqs at this link: http://conky.sourceforge.net/faq.html

Specifically these two questions:

  1. Conky won't stop flickering
  2. Why does Conky make my icons disappear?
share|improve this answer
    
RTFM is not a good answer. –  Seamus Jan 27 '11 at 11:39
    
This is what you should have done at first place. Even after pointing you out to the official guide you are not ready to read it and do it yourself. All you need is a ready made answer. If you do not understand the solution mentioned in the faqs then that would have been a different case but being rude like this? –  user8592 Jan 27 '11 at 17:51
1  
@user8592 I could just point you to our style guidelines, but as they suggest, that isn't the best approach. If you're answer is behind a link, like an outside FAQ, don't just link to it. Summarize the information in your answer. –  andrewsomething Jan 28 '11 at 21:00
    
@andrew I will keep that in mind from next time. Thanks. –  user8592 Jan 29 '11 at 9:37
    
This isn't really a question about conky. I want to make the icons stop appearing in a certain part of the screen. I know they're under conky, that's why I mentioned it, but the question is about making part of my desktop real-estate no-go for new icons appearing. Correct me if I'm wrong but that's outside the remit of conky's manual. –  Seamus Feb 1 '11 at 20:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.