Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

i updated to 12.10 beta 1 when it was released (coming from 12.04 fresh install, i skipped the alpha releases of 12.10)

since then i've done all the usual updates but ive had an issue with my cursor jumping. it does not jump when typing, i've done a lot of searching and cant find an answer, it tends to happen most when i move the cursor the jump is maybe 15-20 pixels down and to the right

it seems like a display issue because if i hover over a link or the x to close a window the cursor will settle in it's down/right position, but the whatever im hovering over will still act as if that's where the mouse is, and clicking still works on the item. so the mouse is actually in its original location, but it's displaying offset and flickering back and forth from its down/right position and its correct position

this makes use very difficult because the mouse is never displayed where it actually is and i have to estimate my clicks

any ideas?

Clarity: the issue I have is on a full install, not virtual box.

share|improve this question
    
is this a virtualbox install or a laptop install? This sounds like a bug. –  fossfreedom Oct 19 '12 at 9:43
    
Primary install on my netbook. Happens with mouse plugged in and using built in track pad. –  nyne Oct 19 '12 at 23:53
    
My upgrade to 12.10 didn't go well... I too have the same issue (I think) Ubuntu 12.10 on Virtual Box 4.2.2 A video of my problem can be seen here: youtube.com/watch?v=U7Pih8pQ37k Does your installation do something similar with what you see on the video? Is there a way to fix this? –  Petsoukos Oct 24 '12 at 9:13
    
I have the same problem too as of today. Ubuntu 12.10 AMD64, ATI HD 4600, Unity desktop. The mouse cursor is making sudden jumps, sometimes it clicks on buttons (or links) without me clicking and often scrolls the screen upwards or downwards without me doing anything. It happens in any application I tested so far, that is the desktop itself, Firefox and Chromium. To make sure I have exchanged the mouse with the result that new mouse shows the exact same behavior. –  user141680 Mar 19 '13 at 14:51
add comment

4 Answers

I use VirtualBox (4.2.4r81684) on a Windows 7 host, had ubuntu desktop 12.04 guest, upgraded to 12.10 recently, and experienced this mouse jumping you describe, even after updating guest additions.

This helped me out:

Long story short: this bug will be fixed eventually. You can either run these commands on EVERY boot (can put into a script in your .bash_profile, or something similar):

xinput set-prop "VirtualBox mouse integration" "Coordinate Transformation Matrix" 0.5 0 0 0 0.5 0 0 0 1.0
xinput set-prop "VirtualBox mouse integration" "Coordinate Transformation Matrix" 1.0 0 0 0 1.0 0 0 0 1.0

OR you can install the bug fix:

sudo apt-add-repository ppa:a7x/bug1041063
sudo apt-get update
sudo apt-get upgrade

I installed the fix, and am happy to say that the problem has been resolved for me.

share|improve this answer
add comment

If you are on a VirtualBox, and your issue is with Ubuntu 12.10. You can avoid this issue by pressing the right hand CTRL + I also called host-i.
This enables and disables mouse integration, because the issue is caused by a mouse integration problem between your host machine and VirtualBox.

If you are not using a VirtualBox virtual machine to run Ubuntu 12.10, but you are using a laptop with a touch pad, here is a website to look at for possible fixes:

You can also disable or enable a touch pad, and many other devices, by following the instructions found in this link.

Other than this, I have not found any other resolutions for this issue.

share|improve this answer
    
Interestingly, with my installtion the problem only occured with the VirtualBox window located on the second screen (which is the one I usually prefer on the system). Moving the window to the first screen fixed the problem (at least as a workaround). –  Marcus Rickert Nov 12 '13 at 9:16
add comment
up vote 1 down vote accepted

A full format and clean install seems to have cleared it up.

share|improve this answer
    
That is how we usually do it in Soviet Russia :) youtube.com/watch?v=tmPG5WfO14A –  Eliah Jan 26 at 17:10
add comment

I am having a similar problem on a Virtualbox install with both touchpad and USB mouse -- my mouse tends to move to position 0 for x and/or y intermittently. I have gnome installed and it was causing the desktop to show the window previews when I'm moving my mouse in the middle of the screen so I disabled the auto-preview in corner feature because it was becoming unbearable.

share|improve this answer
    
Not an answer, but thanks for the comment –  nyne Oct 23 '12 at 11:37
add comment

protected by Community Mar 19 '13 at 15:20

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.