Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

How do I EFI boot Zenbook Prime UX31A from built-in card reader?

Ubuntu Live 12.10 64bit has been copied onto an a SD card which I'm trying to boot from. When I power on my Zenbook and press ESC for the boot menu, the SD card isn't listed as an option. The only device in the list is the internal SDD drive.

There is an "Add boot option" in the BIOS but it requires a few a things that I'm not quite sure of.

  1. Add boot option - I guess any identifier works here. I've been entering ubuntu.
  2. Select Filesystem - The only option available is PCI(1F|2)\DevicePath(Type 3, SubType 12)HD(Part1,Sig787e6287-xxxx-xxxx-xxxx-xxxxxxxxxxxx)
  3. Path for boot option - I've been entering ubuntu:\EFI\BOOT\BOOTx64.EFI

Then I select Create and the new boot option appears in the boot menu but the newly created boot option still points to the internal SDD.

share|improve this question
    
I am having the same issue, did you ever solve this? No matter what I do, I can't get the SD card to appear in my boot menu. –  MrGlass Jul 29 '13 at 18:35
    
I never managed to boot off the SD directly but putting it in a USB card reader worked. I also had to rename a few files on the boot image but can't remember off hand. You'll get a different error when booting off of USB and if you google it, you should be able to find the same thread that I came across. I should have posted the information back in Oct. –  Richard Ayotte Jul 29 '13 at 20:23

1 Answer 1

  1. you must install Ubuntu 64bit, not the 32bit (because it is not EFI compatible)
  2. the path should be /efi/ubuntu/grubx64.efi
  3. If still not good, please connect your SD card, then indicate your Boot-Info URL.
share|improve this answer
    
64 bit was used with the path that you provided and it works if I plug the SD card into a USB card reader which I plug into the USB port but putting the card directly into the laptop's card reader doesn't work. –  Richard Ayotte Feb 24 '13 at 12:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.