Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After I upgraded to Ubuntu 12.10 today, the Plymouth splash screen is not showing when I startup my computer. The screen goes purple at first, then goes black and I am shown the Login Screen.

It showed up when the computer shuts down, though.

Is there a way to make plymouth show again?

share|improve this question
    
try typing sudo update-initramfs –u in the terminal then reboot –  Stephen Myall Oct 19 '12 at 11:02
    
@StephenMyall I tried that but it didn't work :( –  Emerson Hsieh Oct 21 '12 at 2:02
    
possible duplicate of Initial Purple Boot Screen is text not Image in 12.10 –  Mitch Oct 21 '12 at 5:46
    
@Mitch I don't think it's a duplicate. This OP wants it fixed, while the other is just asking if there is anything wrong. –  Stephen Myall Oct 22 '12 at 0:01
    
@Mitch My screen shows nothing while the other guy had a text plymouth. –  Emerson Hsieh Oct 22 '12 at 0:16
show 1 more comment

1 Answer 1

I did the following to fix the problem on my machine:
(found at http://ubuntuforums.org/archive/index.php/t-2066656.html)

  1. gksudo gedit /etc/default/grub

  2. add the following line making sure to put in your native resolution in place of 1680x1050: GRUB_GFXPAYLOAD_LINUX="1680x1050"

  3. sudo update-grub

share|improve this answer
    
This worked for me. Definitely an nVidia driver issue. If I upgrade to EXPERIMENTAL drivers it corrects the problem, however recovering from STANDBY breaks. Thank very much @krumpelstiltskin for posting the solution... –  pst007x Nov 28 '12 at 5:14
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.