Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I would like to set the Caps-lock key as a Compose key, which you do, as far as I remember, by pressing the Options Button in Keyboard Layout > Input Sources and then enabling the appropriate option there. That Button is not pressable though since I switched to 12.10. It did work in previous releases of Ubuntu.

gnome-control-center puts out these errors, when I click on Keyboard Layout:

(gnome-control-center:3645): common-cc-panel-WARNING **: Could not find current language 'Л\u0003C!\u007f' in the treeview

(gnome-control-center:3645): common-cc-panel-WARNING **: locale '"en_US.UTF-8"' isn't valid

I'm not sure if the errors are related though, maybe they are related to the "interface switching to chinese bug" which seems surprisingly widespread:

Language changed to Chinese, how do I change it back?

Language Support has an unwanted Chinese language option

Nautilus Folders Turned Chinese

Desktop 12.04 gnome/cairo suddenly in Chinese

Unwanted Chinese language got set in system settings

I cannot set my system back to English from Chinese Language

Gnome-classic language turned into Chinese, how do I change it back to English?

Strange display language in gnome shell

I'm not sure they are related to this bug, but I just wanted to mention it, maybe it helps!

share|improve this question
add comment

1 Answer

Option button is only available when you have added multiple input sources.

Edit: I found a solution for adding compose key here: http://blogs.gnome.org/mclasen/2012/09/21/input-sources-in-gnome/

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.