Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed ZendStudio 5.5.1 on Ubuntu 12.04 and it runs well , no problem. Today, I download Ubuntu 12.10 and intalled it on my / but keep the /home partition. And now, I can't run the ZendStudio any more, it gives me this error:

strings: '/lib/libc.so.6': No such file ./ZDE: 1714: exec: /home/william/Zend/ZendStudio-5.5.1/jre/bin/java: not found

But the java file exist! What's wrong? Thanks!

I fixed the problem ,it's because I am using 64bit OS and after I run

sudo apt-get install libxss1 lib32stdc++6 lib32asound2 ia32-libs libc6-i386 lib32gcc1

The Zend Studio 5.5.1 can run now.

share|improve this question
add comment

1 Answer

is java installed in general? to find out just run

java -version

it should print out something like

java version "1.7.0_07"
OpenJDK Runtime Environment (IcedTea7 2.3.2) (7u7-2.3.2a-1ubuntu1)
OpenJDK 64-Bit Server VM (build 23.2-b09, mixed mode)

if this is the lib file is just not in place anymore, you should probably check where the file is located at and create a link to it

you can use the find command to do this

find /lib{/,32/} -name "libc.so.6"

if you found the file just create a symbolic link to it and you should be good to go

sudo ln -s /path/to/real/libc.so.6 /lib/libc.so.6

edit:

to fix the missing java run

whereis java

which should print out something like /usr/bin/java

now start ZDE using the parameter LAX_VM, so it should look like this

./ZDE LAX_VM=/usr/bin/java

share|improve this answer
    
Thank you for your reply, I did what you said above and now the message "strings: '/lib/libc.so.6': No such file" disappared, but "./ZDE: 1714: exec: /home/william/Zend/ZendStudio-5.5.1/jre/bin/java: not found" is still there and my ZendStudio still can't work –  William Oct 18 '12 at 23:58
    
find out where your java executable is, use "whereis java", this command should print out the path to the java file. lets asume its /usr/bin/java, now run ./ZDE LAX_VM=/usr/bin/java –  Stefan Oct 19 '12 at 0:24
    
But, ZendStudio has his own jre inside, so ZS should use that one, not /usr/bin/java, right? –  William Oct 19 '12 at 2:55
    
It has its own jre in case the system has no java, there is no actual need to use that specific java version, it just simplifies the installation of it, you can also install it with the LAX_VM parameter, so it'll use the systems jre, long story short, it basically just tells ZDE which java to use, thats it. –  Stefan Oct 19 '12 at 3:07
    
Thank you Stefan! I run "whereis java", it gives me " java: /usr/bin/java /usr/bin/X11/java /usr/share/java /usr/share/man/man1/java.1.gz ", and I tried " ./ZDE LAX_VM=/usr/bin/java ", it gave me same error: " ./ZDE: 1714: exec: /home/william/Zend/ZendStudio-5.5.1/jre/bin/java: not found ", it seems like ZDE only want to use the jre inside it, and the java file does exist, but it said "not found", which is really strange... –  William Oct 19 '12 at 3:19
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.