Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I upgraded to Ubuntu 12.10 using update manager. After the upgrade, the wifi gets connected but would not display any webpages. If I ping 8.8.8.8 or google.com, there is response.

I managed to fix this problem by using the command sudo dhclient wlan0. But, now the problem is that every time I switch wireless networks, I have to give that command. how do I make this permanent?

share|improve this question
add comment

2 Answers 2

up vote 1 down vote accepted

Most likely the symbolic link /etc/resolv.conf -> ../run/resolvconf/resolv.conf is missing on your system. To restore it, do the following in a terminal.

sudo apt-get install resolvconf
sudo dpkg-reconfigure resolvconf

If you want to use 8.8.8.8 as your nameserver then set up either ifup or NetworkManager to use that nameserver address for the interface(s) that it brings up.

If you use ifup then edit /etc/network/interfaces and, in the stanza for the interface in question, add the line "dns-nameservers 8.8.8.8"; then ifdown the interface and ifup it again.

If you use NetworkManager then open the connection editor and add 8.8.8.8 as an additional nameserver address (network indicator | Edit Connections... | Wireless | myconnection | Edit... | IPv4 Settings | Additional DNS servers).

share|improve this answer
add comment

You need to edit your DNS configuration.
Type gksudo gedit /etc/resolv.conf in the terminal. Add your DNS ( eg 8.8.8.8 ) in place of 127.0.0.1.
As pointed out, this configuration may be overwritten. Use resolvconf to modify this file.

share|improve this answer
    
I changed it to gedit for the sake of future inexperienced users. –  hexafraction Oct 18 '12 at 23:24
1  
resolv.conf gets overwritten sometimes. Use resolvconf instead. See askubuntu.com/questions/130452/… –  user68186 Oct 18 '12 at 23:29
    
@ObsessiveSSOℲ resolv.conf is not present starting Ubuntu 12.04 –  Ubuntuser Oct 18 '12 at 23:45
    
@Ubuntuser Why are you addressing this post toward me? I did nor write it. Please address it to the author, Ignite. –  hexafraction Oct 18 '12 at 23:53
    
@Ubuntuser It is present. To know more about it just type man resolv.conf –  IgnitE Oct 19 '12 at 0:06
show 3 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.