Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have GeForce GTX 560 Ti. I's worked fine in 12.04 with nvidia drivers. Unfortunately, after todays 12.10 update, something broke down.

I've tried nvidia-current, nvidia-current-updates and nvidia-experimantal. Always the same behaviour: Bad resolution in lightdm, after logging nothing except wallpaper. No unity panels, "win" key doesn't work.

After removing nvidia drivers everything work.

share|improve this question
    
This should help many users: askubuntu.com/questions/61396/… –  Luis Alvarado Apr 14 '13 at 23:50
add comment

5 Answers 5

up vote 30 down vote accepted

Before switching to the nvidia drivers you need to install linux-source and linux-headers (see bug 1068341). After the source is installed, try switching to the nvidia drivers.

Here is how:

Before you start, install all updates (and reboot the computer, if you are told to).

  1. Switch to a terminal (Ctrl-Alt-F1).

  2. Login as your username.

  3. Install linux source (sudo apt-get install linux-source) and headers (sudo apt-get install linux-headers-generic).

  4. Uninstall nvidia driver - this depends on which version you installed (sudo apt-get remove nvidia-current or sudo apt-get remove nvidia-current-updates or sudo apt-get remove nvidia-experimental-304).

  5. Reinstall nvidia driver (sudo apt-get install nvidia-current-updates).

  6. If it successfully installs, restart the computer (sudo shutdown -r now).

More In-depth How-to

The following link gives a more in-depth overview on how to handle the nvidia driver. It should be applicable to more cases, that are similar, but not exactly the same as the one described here:

https://help.ubuntu.com/community/BinaryDriverHowto/Nvidia

share|improve this answer
    
I've installed linux-source and then nvidia drivers, but still the same problem. –  konradk Oct 18 '12 at 21:39
    
I wasn't sure if linux-headers was necessary, but try installing them. It should be linux-headers-3.5.0-17-generic in the software center. Then try switching to the nvidia drivers. If that doesn't work, I have a more 'manual' way :) –  rft183 Oct 18 '12 at 21:45
    
Yes, that's it:bugs.launchpad.net/ubuntu/+source/… Linux headers helped. Thank you! –  konradk Oct 18 '12 at 22:22
    
Cool, I'm glad it worked. I added myself to the list of people that bug affects. –  rft183 Oct 18 '12 at 22:27
    
Do I have to install the nvidia-current-updates? Or can I get the nvidia-current or nvidia-expetimanetal-304? –  Shahe Tajiryan Oct 22 '12 at 11:52
show 8 more comments

For all of you in this situation (like I was) there is a easy solution:
1- After logged in the session (only wallpaper seems to appear and bad resolution), right click and click on change wallpaper. Then click up in the left in Show all configurations (my system is in Spanish so maybe the label names are subtly different), then Software sources and finally you just need to change back to X.Org Nouveau.
2- After applying the changes press Ctrl+Alt+T to open a terminal and type "sudo reboot". After this the system should be working properly again.
3- Now lets try lo install the NVIDIA drivers again. Open a new terminal and type "sudo apt-get install linux-headers-generic" to install the meta package, not a specific version which is a better approach.
4- Go to system configuration panel and in the software sources select the NVIDIA driver you prefer (I normally prefer to use the privative tested one but it is only my preference)

share|improve this answer
    
Thanks for pointing out the linux-headers-generic metapackage. I have updated my answer to reflect that. –  rft183 Oct 23 '12 at 14:24
add comment

In the special case of a Ubuntu 12.10 with Nvidia hardware acceleration on a Macbook Pro Retina this set of instructions was tested and works correctly.

share|improve this answer
add comment

For step by step instructions to resolve the issue follow rft183's answere.

If something goes wrong

To use the nouveau driver again run the command:

sudo apt-get install xserver-xorg-video-nouveau --reinstall

Afterwards the monitor resolution could not be set anymore. Deleting the monitors config helped:

rm ~/.config/monitors.xml

share|improve this answer
    
In my case, the problem persisted. I noticed that using a guest account, everything was fine, so it a user setting was broken. 'dconf reset -f /org/compiz' solved the issue (though some compiz settings were resetted also) –  Bachi May 10 '13 at 12:48
add comment

I only had to sudo apt-get install linux-headers-generic and reboot. So I just:

  1. Switched to terminal by pressing <Ctrl><Alt>F1 and logged in.
  2. sudo apt-get install linux-headers-generic.
  3. sudo reboot.

My system came up at normal resolution and when I logged in Unity, etc. once again loaded.

share|improve this answer
add comment

protected by Community Oct 22 '12 at 18:46

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.