Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Today I installed the new Ubuntu 12.10 (fresh install) and I noticed that Google Chrome was in the wrong language. I am Portuguese, from Portugal, and Google Chrome is now on Brazilian Portuguese (which is kind of annoying).

I had this problem before, but downloading the DVD edition of the OS would fix the problem (Google Chrome would be in PT-PT on a DVD installation).

The problem is that Ubuntu 12.10 doesn't have a DVD specific edition... So, how can I manualy change Google Chrome's language?

share|improve this question
    
Can you check to see what language is set as default for your Ubuntu installation? –  CoalaWeb Oct 19 '12 at 7:11
    
It's Portuguese(Portugal)... –  joelalmeidaptg Oct 19 '12 at 10:23

3 Answers 3

In your /usr/share/applications/google-chrome-stable.desktop change the "exec" command to something like this:

Exec=sh -c "export LANGUAGE=pt_BR.UTF-8 && /usr/bin/google-chrome-stable %U &"
share|improve this answer
    
Thank you. Your answer worked perfectly fine. BTW, it's actually sufficient to just supply LANGUAGE as a local variable, e.g. sh -c "LANGUAGE=en /opt/google/chrome/google-chrome %U" –  Glutanimate Oct 8 at 8:04

Go to Customize and control Google Chrome (wrench that side Omnibox)> Congfigurações> Show Advanced Settings> Languages> Language Preferences and spelling checker> Portuguese> Ok

As shown, this language can not be used in spell checker, I recommend turning off

share|improve this answer
1  
It didn't work, Chrome is still PT-BR... –  joelalmeidaptg Oct 18 '12 at 21:33
    
I can confirm. That isn't a solution to the problem described by the user. –  DeLiK May 13 at 17:59

I think it's a matter of downloading the Portuguese version from here: https://www.google.pt/intl/pt/chrome/browser/

Alternatively you can use Chromium (see differences between Chrome and Chromium) and download it from the software center. I'm pretty sure it will automatically be in the system language, so in your case Portuguese-Portuguese.

share|improve this answer
    
I did. Chrome will be in Portuguese (Brazilian) even if downloaded from the Portuguese site. This is a issue that happened to me on every CD version of Ubuntu (downloading the DVD would fix the problem). But there isn't a DVD version for quantal... –  joelalmeidaptg Oct 22 '12 at 18:50
    
Alright. I've read up on it and I think it's intentional as Brazilian-Portuguese and Portuguese-Portuguese are the same now: "This spelling reform went into effect in Brazil on January 1, 2009. In Portugal, the reform was signed into law by the President on July 21, 2008 allowing for a 6-year adaptation period, during which both orthographies will co-exist". I guess Google thought it was time to make the change. –  duxk.gh Oct 22 '12 at 19:55
    
Well, they are doing wrong again. The two languages are VERY different from each other... The orthography agreement was just for words that were written differently, not the way they are used. Whatever, I'll just stick with Precise for now. –  joelalmeidaptg Oct 22 '12 at 20:37
    
sorry to not be of much help. if i were you i'd give chromium a try! –  duxk.gh Oct 22 '12 at 21:45
    
I tried chromium. PT-BR as well xD –  joelalmeidaptg Oct 23 '12 at 11:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.