Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have followed this guide to install nvidia driver on my Dell Inspiron N5110 notebook (Intel HD Graphics 3000 + NVIDIA GeForce GT525M), but i always get some error while i want to start any program with the optirun command.

Terminal says:

adam@Adam-LT:~$ optirun firefox
[ 1482.559417] [ERROR]Cannot access secondary GPU - error: Could not load GPU driver

[ 1482.559517] [ERROR]Aborting because fallback start is disabled.

My laptop cooler always cools the laptop, which means that nvidia card is consuming power in the background. (Terminal sometimes says something daemon-server is not running.) Can you give me some solution for this?

share|improve this question
up vote 12 down vote accepted

I recently had this problem as well.

For me, all I had to do was run the following commands. I'll break them down:

sudo apt-get install ppa-purge
sudo apt-get purge bbswitch-dkms bumblebee-nvidia

That installs the PPA-Purge utility and removes BBSwitch and Bumblebee

sudo apt-get install linux-headers-generic

That installs the proper Linux headers. For some reason, BBSwitch wouldn't (for lack of a better word, insert) itself into the kernel.

Then a simple

sudo apt-get install bbswitch-dkms bumblebee-nvidia

fixed everything. Oh, and a reboot, of course :)

Hopefully this will help you at least a little bit! Please let me know how you go

share|improve this answer
Thanks man. You have saved my battery life :) – Adam Oct 19 '12 at 9:01
I think it is sufficient to run sudo apt-get install linux-headers-$(uname -r) && sudo dkms autoinstall && sudo restart bumblebeed. That installs the stuff to get bbswitch compiled and restarts bumblebeed so that is able to detect bbswitch. – Lekensteyn Oct 20 '12 at 8:26
Worked for me too, great! – Makario Nov 5 '12 at 4:27
Thanks a lot, works like a charm now – suther Oct 17 '13 at 18:57

On an upgrade from Ubuntu 12.04 to 12.10 it is logical that bumblebee has been installed before. The PPA however becomes disabled on the upgrade, so you will need to enable it again!

sudo add-apt-repository ppa:bumblebee/stable
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install bbswitch-dkms bumblebee-nvidia

At this moment the new version of bumblebee will be installed as well as nvidia-current as it is a dependency of bumblebee-nvidia.

If your home directory is encrypted the installation process will hang at update-initramfs. This can be solved by disabling FRAMEBUFFER=y in /usr/share/initramfs-tools/conf-hooks.d/cryptsetup

# This will setup non-us keyboards in early userspace,
# necessary for punching in passphrases.

# force busybox on initramfs

# and for systems using plymouth instead, use the new option
# FRAMEBUFFER=y  # DISABLED to install nvidia drivers

Now optirun works perfectly on my system, Geforce GT 650M, on an Asus N56V.

share|improve this answer

Did you try " optirun glxspheres " from the guide? And what does is say ? Mine says;

toddi@ubuntu-e530:~$ optirun glxspheres Polygons in scene: 62464 Visual ID of window: 0x21 Context is Direct OpenGL Renderer: GeForce GT 630M/PCIe/SSE2

according to this more official site; " " - that I followed - it says to run " sudo apt-get install bumblebee-nvidia " witch it seems not to do in the guide you linked to.

!! NOTE !! I no expert. This is just what I did - and it seems to work here. I have not tested anything else than the first command - just got this computer, and since I am most interested in saving battery.

share|improve this answer
adam@Adam-LT:~$ optirun glxspheres [ 4817.799920] [ERROR]Cannot access secondary GPU - error: Could not load GPU driver [ 4817.800070] [ERROR]Aborting because fallback start is disabled. – Adam Oct 18 '12 at 21:27

Tried the above no luck - here is my post from another attempt to get things fixed. Any help would be much appreciated.

I have been trying to get proprietary graphics working with my brand new HP Envy 17 m7-j078 notebook. I had been trying for 2 1/2 years with my previous HP Laptop with no success and TRIED EVERYTHING - Over and Over. It had ATI Muxless Hybrid Graphics with its' Intel I7. I thought this one with its Optimus NVIDIA GeForce GT 740M dedicated card would solve the problem because of all the blogs saying Bumblebee works like a charm. It has now been 2 weeks and over 20 attempts and 5--10 re-installs of Ubuntu Linux Mint, and still no luck.

Perhaps someone can help me troubleshoot this and stop spinning my wheels and get me out of this rabbit hole, while even learning something, so I can help all the others I have convinced to get into Linux. Thanks in advance, thanks a lot.

Here are some details that may be useful (in no specific order)

• HP Envy Touchsmart m7-j078ca notebook • Intel® Core™ i7-4700MQ • NVIDIA GeForce GT 740M (2 GB DDR3 dedicated) • Linux Mint 16 Petra

• Bumblebee 3.2.1 • ack@Aarawn ~ $ lspci -vnn | grep '\''[030[02]]' 00:02.0 VGA compatible controller [0300]: Intel Corporation 4th Gen Core Processor
Integrated Graphics Controller [8086:0416] (rev 06) (prog-if 00 [VGA controller]) 01:00.0 3D controller [0302]: NVIDIA Corporation GK208M [GeForce GT 740M] [10de:1292] (rev a1) ∘ Note that here it doesn't say 01:00 is a "VGA" Controller but a "3D Controller" • ack@Aarawn ~ $ sudo modprobe nvidia [sudo] password for ack: FATAL: Module nvidia not found.

• installed ∘ bumblebee-nvidia primus ∘ nvidia-304 nvidia-current (304) nvidia-prime nvidia settings nvidia settings-304 • Xorg.conf with any mention of Nvidia results in TTY1 X crash and only deleting sometimes returns mdm to functioning order

• $ optirun firefox ∘ [ 1228.929955] [ERROR]Cannot access secondary GPU - error: Could not load GPU driver ∘ [ 1228.929986] [ERROR]Aborting because fallback start is disabled.

• ack@Aarawn ~ $ sudo gedit /etc/bumblebee/xorg.conf.nvidia Section "ServerLayout" Identifier "Layout0" Option "AutoAddDevices" "false" Option "AutoAddGPU" "false" EndSection

Section "Device"
        Identifier  "DiscreteNvidia"
        Driver      "nvidia"
    VendorName  "NVIDIA Corporation"
        Option "ProbeAllGpus" "false"
        Option "NoLogo" "true"
        Option "UseEDID" "false"
        Option "UseDisplayDevice" "none"

• ack@Aarawn ~ $ bumblebeed ∘ [ 3052.038351] [ERROR]Module 'nvidia' is not found.

I am going to try a number of other things, but am getting exhausted and would really appreciate a fresh perspective on this issue. Thanks again.


share|improve this answer

protected by Community Jun 10 '13 at 19:26

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.