Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to access the MYSQL installed inside the Ubuntu Guest (In VirtualBox) from my Windows vista Host. It always says not able to find the given IP in the network.

I have tried ping the ubuntu virtual machine, but it was not working. So i believe root cause for this is, some bridging between Host & Guest is not enabled. Since i am very new to Ubuntu, am not able to troubleshoot this.

My Current settings:

 Virtual box network adapter is attached to NAT

Can someone help me out?

Cheers

share|improve this question
    
Question about your network - are you on your own router, and are you able to get your own static IP's, or are you DHCP only? –  Danny Staple Jan 6 '11 at 7:31
    
@Danny, no static ips. Its just standaalone vista machine have ubuntu guest installed.... –  RameshVel Jan 6 '11 at 7:33
    
Which network settings do you have for the VM in vbox? Do you require other computers on the network to be able to access the vm? Do you require the vm to have access to the internet? –  Danny Staple Jan 6 '11 at 7:52
    
@Danny, My current n/w adpters is attached to NAT in VirtualBox. and I dont need other computers in the network to access the guest.. Yes i require guest to have an interent access –  RameshVel Jan 6 '11 at 8:02
add comment

1 Answer

up vote 2 down vote accepted

Configure virtual machine to use Host only network adapter and enable internet connection sharing on your Vista host. I believe this will solve your problem. If you are not able to access internet on guest then try using windows IP as default gateway in your Ubuntu guest.

share|improve this answer
    
I'd back this - also I suggest before trying to access mysql, start with the basics - try pinging the vbox machine from the host. –  Danny Staple Jan 6 '11 at 12:36
    
thanks, it works... :) –  RameshVel Jan 6 '11 at 15:13
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.