Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've install Ubuntu 12.10 and now I can't mount any partitions.

I get the same error with drives: Adding read ACL for uid 1000 to /media/proach failed: Operation not supported

share|improve this question
    
It seems to be a bug, as reported here: bugs.launchpad.net/ubuntu/+source/linux/+bug/1048059 –  jasmines Oct 19 '12 at 15:24
    
"proach" from "/media/proach" being Konstantin's user name.. –  aleb Nov 17 '12 at 19:02

8 Answers 8

I have one word for this 'bug': fun. :) I saw exactly the same error message today, and the solution is...

sudo mkdir /media/$USER
sudo chown $USER.$USER /media/$USER

(thank jasmines for the tipp!)

I know, fun, but that was the solution for me! Ubuntu wants to use a non-existent directory for the mount target, and doesn't create it before attempting the mounting operation!

share|improve this answer
    
Better sudo chown USERNAME.USERNAME /media/USERNAME. Please, edit your answer so I can award the bounty! –  jasmines Oct 23 '12 at 10:31

Just follow instructions:

sudo blkid
sudo gedit /etc/fstab

and fill informations= in given pattern, mine was:

UUID=445F-4D4E /home/str007/kortele vfat errors=remount-ro 0 1

My file now looks like this

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda2 during installation
UUID=69ede51f-a51e-4493-9c86-e553f952b3e6 / ext2    errors=remount-ro 0   1
UUID=445F-4D4E /home/str007/kortele vfat errors=remount-ro 0 1
share|improve this answer

I created a directory in /media with my user name and with read-write privileges for me. This worked OK, since I'm the only user on this computer, but it would be a pain with more users or changing users.

share|improve this answer

As @jasmines points out it's a known bug. The ACL change is not really needed to mount, but it's attempted if the directory doesn't exist.

  • As others point out, you can just create /mount/$USER.
  • The error happens when your root filesystem doesn't support acl. You can enable acl support by editing /etc/fstab (see details in bug).
  • The final fix was just not touching ACLs if unsupported. You can get this fix it by installing udisks2 from quantal-proposed. Enabling proposed will offer you tons of upgrades; it's simpler to just install the .deb.
share|improve this answer

the suggestion to mkdir + chown is right! For absolute beginners, the following command will tell you your username

whoami
share|improve this answer

You can mount manually of course by: sudo mount /dev/sdx1 /mnt/mountpoint. I know it'a pain compared to 12.04...but it works.

share|improve this answer

I had the same problem with both a usb device and my primary (windows) partition. I managed to mount my windows partition by opening the "disks" application, selecting my primary partition, clicking "more actions..." (just below partition) >> "edit mount options" >> and beside "Identify as" I selected /dev/sda1.

This allow me to mount my windows partition but it didn’t work for my usb device

share|improve this answer

The last answer make a solution in some cases...

I just found a solution 100% effective. Follow my instructions:

1) In a console write that: $ sudo gedit /etc/fstab

2) Enter your admin password

3) In the gedit Editor, go to the end of the file and write your data with this structure: #Hard Drive n1 the next line auto-mont the partition sda2 in the /media directory /dev/sda2 /media/myHardDrive ntfs defaults 00 #For CD/DVD the next line auto-mont the CD/DVD in /media dictory with the type iso966 /dev/sr0 /media/CD-DVD iso966

4)save the current text and close de gedit editor.

If all of this works, when you insert a DVD, Hard Drive or any device, they will auto-mount in the directory that you put in the /etc/fstab file.

Of course, if you are any question or error in the steps, i will write as soon i can.

share|improve this answer

protected by Community Feb 19 '13 at 21:58

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.