Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm currently running Ubuntu 12.04 (sort of) on my x86 desktop system.

(Actually my /etc/lsb-release says:

DISTRIB_DESCRIPTION="Ubuntu quantal (development branch)"

probably because I installed a beta release of 12.04 shortly before the official one came out.)

I'd like to upgrade to the new 12.10 (non-beta) release. The usual way to do this is to use the update manager -- but when I run update-manager or any apt-* command (at least the ones I've tried), it dies with a segmentation fault. Here's what gdb has to say when I try to run apt-cache:

$ apt-cache --version
apt 0.8.16~exp12ubuntu10.3 for i386 compiled on Aug 20 2012 22:34:48
$ gdb apt-cache
(gdb) run search git
Starting program: /usr/bin/apt-cache search git

Program received signal SIGSEGV, Segmentation fault.
0xb7ee16ce in pkgCache::VerIterator::TranslatedDescription() const () from /usr/lib/i386-linux-gnu/
(gdb) where
#0  0xb7ee16ce in pkgCache::VerIterator::TranslatedDescription() const () from /usr/lib/i386-linux-gnu/
#1  0x08051bd1 in ?? ()
#2  0xb7eccf6e in CommandLine::DispatchArg(CommandLine::Dispatch*, bool) () from /usr/lib/i386-linux-gnu/
#3  0x0804e833 in ?? ()
#4  0xb7c044d3 in __libc_start_main (main=0x804e520, argc=3, ubp_av=0xbffff964, init=0x805bdf0, fini=0x805be60, 
    rtld_fini=0xb7fed270 <_dl_fini>, stack_end=0xbffff95c) at libc-start.c:226
#5  0x0804e8f1 in ?? ()

The dpkg command doesn't have this problem.

I've tried reinstalling libapt-pkg4.12 (the package that provides /usr/lib/i386-linux-gnu/, and it didn't help.

My goal is to upgrade to 12.10 (not beta) and have update-manager and the apt-* commands working properly.

Can I update my existing system from a DVD or USB thumb drive (I'm downloading ubuntu-12.10-desktop-i386.iso right now) without wiping out my existing files?

If not, can I reinstall or repair my libapt-pkg4.12 and/or apt packages and get apt-* and update-manager working again?

If not, I suppose my remaining option is to install 12.10 from scratch and then restore my files from a backup -- which I'll do if I have to, but I'd rather leave my files in place. (I have a backup anyway in case something goes wrong during a normal upgrade.)


A Google search for the error message (which I should have done before) led me to bug #970988, which refers to a crash in the same TranslatedDescription() routine. It's closed as a duplicate of bug #938116. It's supposedly fixed by update-manager 1:0.156.12 -- but I already have update-manager 1:, and I'm still getting the crash. I don't see anything in either bug report that suggests a way to fix the problem on my system (other than reinstalling).

One of the bug reports mentions that somebody encountered the bug after installing Skype, and fixed it by uninstalling Skype. I happen to have installed Skype around the time this problem showed up, but uninstalling it hasn't helped.

share|improve this question
Hi! How does your problem go? Is it solved till now? – Danatela Apr 30 '14 at 9:03
@Danatela: No, I've just learned to live with it. Since I posted this, I got a new computer and installed Linux Mint on it. The old one is still running without updates. Eventually, after I migrate everything to the new system, I'll either reinstall the old one from scratch or just retire it. – Keith Thompson Apr 30 '14 at 21:24
You can update your system from installation media. However, all additional packages will be uninstalled. And if you selected reiserfs as your root filesystem, you will not be able to update to 13.10 using this method. I suggest you to update to 12.10 via LiveCD/LiveUSB then update via update-manager. – Danatela May 7 '14 at 9:59

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.