Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am now unable to connect to internet with a huwaei E173s-1.

The modem worked perfectly in 11.04, 11.10 and 12.04 now it gets detected, but cannot be connected at all.

Any help is more than welcome!

share|improve this question

Yes I've had the same problem with two other devices after update 12.10 (worked fine with 12.04).
My Solution downgrade modem-manager (to deb of 12.04)

download deb:
from (

and the install the old version:

sudo dpkg -i modemmanager_0.5.2.0-0ubuntu2_i386.deb

to prevent update to version 0.6.x lock the version in synaptic.
After downgrade I got the question for PIN immediately.

NOTE: Give ubuntu a change to repair, so keep in touch of update of 0.6.x version ;-)

share|improve this answer

There is a bug in ModemManager which comes with Ubuntu 12.10.

You should use ModemManager

Install the following packages:

After reboot works the Modem fine.

share|improve this answer
thanks that solved the issue...! – malikdhadha Oct 26 '12 at 10:18

Edit /etc/network/interfaces by

sudo nano /etc/network/interfaces in terminal

Conform that file should have following parameters.

auto eth0

iface eth0 inet dhcp

Save file reboot system.

share|improve this answer

I have manual steps to configure it.

  1. First of all open up the terminal and run the following command

    sudo apt-get update

  2. Now we need to install wvdial so run the following command

    sudo apt-get install wvdial

  3. Now we need to install libusb-dev so run the following command

    sudo apt-get install libusb-dev

  4. Now we need to download usb-modeswitch and usb-modeswitch-data so go to the following links usb-modeswitch usb-modeswitch-data . Download both the files and save them on your computer .

  5. Now extract both the files and and go to extracted directories on by one (first go to usb-modeswitch). and run the following command as root

    sudo make install

  6. Now run the following command

    sudo gedit /etc/usb_modeswitch.conf

and it will open gedit and paste the following text in it and save the file

# Configuration for the usb-modeswitch package, a mode switching tool for
# USB devices providing multiple states or modes
# This file is evaluated by the wrapper script "usb_modeswitch" in /lib/udev
      # To enable an option, set it to "1", "yes" or "true" (case doesn't matter)
# Everything else counts as "disable"
# Disable automatic mode switching globally (e.g. to access the original
      # install storage)
# Enable logging (results in a extensive report file in /var/log, named
# "usb_modeswitch_"
# Huawei, newer modems
DefaultVendor= 0x12d1
TargetVendor= 0x12d1

   7.  Now run the following commands

`sudo gedit /etc/wvdial.conf`

it will again open gedit and you need to paste the following text in it.

[Dialer netconnect]
New PPPD = yes
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Modem Type = USB Modem
Baud = 460800
New PPPD = yes
Modem = /dev/ttyUSB0
ISDN = 0
Username = 93********
      Password = 93*********
Phone = #777
Stupid Mode = 1
Auto DNS = 1
Check Def Route = 1

change the username and password with your 10 digit MDN number given on the box of datacard. 8. Now Save the file and reboot the computer. After reboot plugin your datacard and wait for 5 to 6 seconds . Now run the following command

sudo wvdial netconnect

you should see something like below after running the above command

--> Using interface ppp0
--> local  IP address
--> remote IP address
--> primary   DNS address
share|improve this answer
The following links in step 4 never did follow... – Mark Paskal Oct 23 '12 at 10:10

An alternative easier solution is to start your modem in windows OS, and configure it to use a hybrid mode. Usually, your vendor includes drivers that work out-of-the-box but only on Windows. For example, Tata-Photon includes a GUI tool that enables you to switch between Photon-Plus, Plug-to-surf and Hybrid-mode. The third option will enable your broadband to work out of the box even on linux without installing wvdial or doing other advanced configurations.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.