Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried to resize my data partition with gparted, from a ubuntu 12.04 live usb. I then accidentally closed my laptop screen, which caused ubuntu to hibernate. After I tried to get it back up, the screen kept black and the hdd indicator didn't blink. I then rebooted (again to my live usb). Gparted shows now that the partition is of the desired size, but it can't detect the filesystem. I found out that the superblock went bad, and tried the instructions found here. After trying all superblock backups (16), I am still stuck. Can anyone help me with the next step?

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

The next step is to restore from backup; your data is toast.

If you don't have backups ( and this will be a hard lesson if you don't ) then you can pray, and try using photorec from the testdisk package. You will need to boot from a livecd and have another disk to store any files it recovers on, then you will have to sort through and try to figure out what they are because the names will be unrecognizable.

share|improve this answer
1  
Thanks for the answer. Read somewhere (can't find it back) that it is possible to recreate the superblock (linux.die.net/man/8/mke2fs, read the -S option). Could I try this, or is that of no use? –  Swiizard Oct 18 '12 at 15:26
    
It is of no use... the superblock isn't the problem.. the problem is that half of the data has been moved and half has not... how much and where is unknown. –  psusi Oct 18 '12 at 23:04
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.