Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm having the same problem with 12.04.01 as Eeesy in a previous post. I use the link in Kubuntu to invoke the installer to 'Install Mozilla Firefox Browser.' (By 'invoking the installer' I mean K menu-->Applications-->Internet-->'Mozilla Firefox Browser Installer') I go through the installation dialogue boxes, and it indicates Package successfully installed. After this, I do not seem to be able to locate the link to Firefox. (I have tried: which firefox and which Firefox, neither of which result in a path.)

I have also tried: sudo apt-get install firefox

[sudo] password for chphunk:  
Reading package lists...  
Done Building
dependency tree  
Reading state information...  
Done Package firefox is
not available, but is referred to by another package. This may mean
that the package is missing, has been obsoleted, or is only available
from another source

E: Package 'firefox' has no installation candidate

When I browse the Muon Software Center, it shows Firefox Web Browser as installed. When i select 'More Info', it indicates 'Find in the menu: K --> Applications -->Internet -->Mozilla Firefox Browser Installer.

I just want to run Firefox. Can you offer any guidance here? Thanks in advance.

share|improve this question
add comment

1 Answer 1

Here are three ways to install firefox on Kubuntu 12.04. Make sure you enabled all the repositories and do an sudo apt-get update in the konsole program.

  1. Install from the konsole with sudo apt-get install firefox.
  2. Alternatively you can install the Firefox by clicking on the Firefox installer icon in the start menu (or Kickoff menu). Search for it by typing "Firefox" in the start menu.
  3. Another alternative, (which the OP followed to solve his issue) is using Muon software center. Open it, Go to Get softwareInternetWeb Browsers and select FireFox Web browser and click on the Install button next to it's label.
share|improve this answer
    
Problem resolved. –  Chris Primo Oct 18 '12 at 14:02
1  
If your problem is resolved by following the answer, you may want to accept the answer. Or if it is resolved by following another process, i suggest you to add your own answer –  Anwar Shah Oct 18 '12 at 14:03
    
A.S., I did as you advised, but I found resolution by installing through Muon thusly, I selected 'Get software->Internet->Web Browsers'. This allowed me to choose the installation of 'Firefox Web Browser' This created the link automatically in my 'K' menu. Thank you. –  Chris Primo Oct 18 '12 at 14:11
    
@ChrisPrimo yes, that is another option though. Both do same thing. Thanks –  Anwar Shah Oct 18 '12 at 14:19
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.