Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am using Ubuntu 10.04.4 LTS on my DELL Vostro 1400 laptop.
Today afternoon when i ran sudo apt-get upgrade i got a error.

Googled for it, but there was no particular workarounds suggested for it.
Heres the error:

ubuntu@ubuntu-laptop:~$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 280 not upgraded.
2 not fully installed or removed.
After this operation, 0B of additional disk space will be used.
Setting up x11-common (1:7.6+8~bpo60+1) ...
Template parse error near `Choices-sr@latin.UTF-8: Samo glavni korisnik, Samo za korisnike konzole, Svako', in stanza #1 of /var/lib/dpkg/info/x11-common.templates
dpkg: error processing x11-common (--configure):
 subprocess installed post-installation script returned error exit status 9
dpkg: dependency problems prevent configuration of xserver-common:
 xserver-common depends on x11-common; however:
  Package x11-common is not configured yet.
dpkg: error processing xserver-common (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

Any ideas on what could be the issue?

share|improve this question
up vote 2 down vote accepted

I found the cause, it was due to squeeze-backports entry in the sources.list.
Seems un compatible DEBs were being installed
Removed the entry.
And Re-Ran update, but still apt-get upgrade gave same error.

Then after a lot of meddling with commands, i ran sudo aptitude remove x11-common
It proposed a solution to downgrade x11.

The following actions will resolve these dependencies:

Downgrade the following packages:
x11-common [1:7.6+8~bpo60+1 (now) -> 1:7.5+5ubuntu1 (lucid)]

Score is -9979

Accept this solution? [Y/n/q/?] 

Gave 'Y' and it resolved the mismatch.
Later i ran apt-get upgrade which installed the latest deb of x11 for Ubuntu.
All is well now :D

share|improve this answer
Thank you so much for posting your answer. This saved the day! – Nathan Nov 18 '12 at 1:39

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.