Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried to install Heroku in Ubuntu using this script

wget -qO- https://toolbelt.heroku.com/install-ubuntu.sh | sh

and I get this error while installing heroku-toolbelt package

Failed to fetch http://toolbelt.heroku.com/ubuntu/./foreman-0.60.0.deb  Size mismatch
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

I tried to download "http://toolbelt.heroku.com/ubuntu/./foreman-0.60.0.deb" manually to /var/cache/apt/archives/ but didn't work with the same error.

Any ideas to get this thing installed ?

share|improve this question

1 Answer 1

up vote 4 down vote accepted

The mirror in your software sources might not be up-to-date. Try changing the mirror in software sources.

Also try out the alternate way of installation. Using the below commands

sudo apt-add-repository 'deb http://toolbelt.herokuapp.com/ubuntu ./'
wget -O- https://toolbelt.heroku.com/apt/release.key | apt-key add -
sudo apt-get update
sudo apt-get install heroku-toolbelt
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.