Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

i had been using bluetooth fine, with devices working, but today when i turned on my computer again bluetooth strangely failed.

there is a bluetooth icon on the top bar, showing "bluetooth on", but if i click on the "bluetooth settings" item, a system settings window shows up and shows me a bluetooth on-off switch which is disabled (i.e. fixed to off).

more information about my case:

  • i am a new linux used, coming from windows, and do not know supposedly-obvious commands.
  • i am using a laptop. it initially doesn't have bluetooth. i bought a built-in type (instead of USB type) bluetooth module, and added it inside the laptop. hence, i do not have a specific FN+* key for bluetooth. in windows, i needed to install an additional driver that was intended for other machines in my laptop's seires which have built-in (i.e. factoryly built-in)j bluetooth modules. the Fn+* key seemed to only affect wifi under ubuntu.
  • i have been successfully using magicmouse with my later-added built-in bluetooth module/adapter on both windows and ubuntu
  • i have been trying to tweak the magicmouse scrolling speed with commands rmmod something, modprobe hid_magicmouse --scroll_speed=45 --scroll_acceleration=30 or something, then added a file `/etc/modprobe.d/magicmouse.conf". the mouse seemed to be working fine with these changes.
  • now if i run commands like hcitool dev, the shell tells me that i do not have any "Devices" or "adapters".
  • i seem to have bluez installed, because when i type "blue" then tab-autocomplete, a bunch of commands like bluez-test-device pops up.

-- update --

some commands and their results:

easoncxz@eason-Aspire-4741-ubuntu:/etc$ hcitool dev
Devices:
easoncxz@eason-Aspire-4741-ubuntu:/etc$ hcitool scan 
Device is not available: No such device
easoncxz@eason-Aspire-4741-ubuntu:/etc$ rfkill list 
0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: acer-wireless: Wireless LAN
    Soft blocked: no
    Hard blocked: no
2: acer-bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: no
easoncxz@eason-Aspire-4741-ubuntu:/etc$ rfkill list 
0: phy0: Wireless LAN
    Soft blocked: yes
    Hard blocked: no
1: acer-wireless: Wireless LAN
    Soft blocked: yes
    Hard blocked: no
2: acer-bluetooth: Bluetooth
    Soft blocked: yes
    Hard blocked: no
share|improve this question

1 Answer 1

Just figured this out and had the same symptoms as you. Make sure your Bluetooth is enabled in BIOS/UEFI. If it isn't it won't work :)

share|improve this answer
    
The post was from a long time ago; now I'm not even using the same laptop... However, I don't think the BIOS settings led to this problem, because bluetooth had been working fine before, on both Windows and Ubuntu, without BIOS settings changed or cared about. –  easoncxz Sep 11 '13 at 1:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.