Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I used geany and g++ on Ubuntu, they were working just fine.

But now I just installed Kubuntu, and geany just doesn't work as usual. Geany builds and compiles with g++, but it cannot run the file. What I see is a blank console screen every time I ran a cxx file.

Geany commands:

compile : g++ -Wall -c "%f"
build : g++ -Wall -o "%e" "%f"
excute : "./%e"
share|improve this question
    
i have same problem have you figured it out or not?? –  SidhuHarry Nov 3 '12 at 19:14

1 Answer 1

I am not sure how old the post is, but here's a solution to the KDE compilation issue. I, too, was faced with this problem. I just went to the Geany website and checked the documentation for a solution.

To save you the trouble of searching, I am going to post the way to fix the problem here.


  1. Go to Edit and click on Preferences.

  2. Select the Tools tab and enter the following command in the field Terminal:

    urxvt -e sh -c
    

or

konsole -e sh -c

or (in case the above failed)

konsole --workdir . -e sh geany_run_script.sh 

I tried this and it worked for me.

I really love the Geany IDE and didn't want to part with it, especially on KDE which I also favor.

Cheers.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.