Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This might sound strange but, working with my Lubuntu 10.04 i've experienced troubles when connecting to my eth0 newtwork. After some googling, i've found out that by writting in the CLI the following command:

mii-tool eth0 -F 10baseT-FD

and activating the eth0 in the toolbar (by clicking "activate eth0") everything works just fine.

Well, up to now, i did not have any problem, because every time i turned on the computer i had to do this, but it was very little effort.But now, i would like to use the machine as a file server, accesing it by ssh, without monitor or keyboard. So, i won't be able to make this actions, and can't do this at startup because mii-tool needs root permissions. So, the question is:

Do you know what does that command do, and how can id make that change permanent? Or do you know any other solution for my problem?

I hope i was clear! If not, tell me and i'll try to be as clearer as possible.

Thanks in advance!

share|improve this question
add comment

2 Answers

It looks like you can do this with ethtool, and make the change permanent by modifying /etc/network/interfaces.

Something like:

auto eth0
iface eth0 inet static
pre-up /usr/sbin/ethtool -s eth0 speed 10 duplex full

There's a page with the info here: https://help.ubuntu.com/10.04/serverguide/C/network-configuration.html

share|improve this answer
add comment

The miitool command is forcing the connection to 10 Megabits/sec Full duplex. This is required when the other end of the connection does not broadcast its capabilities.

miitool is obsolete, and should be replaced with ethtool as shown by @jasonbrooks. You could use your command in place of the ethtool command shown.

ethtool can be used to determine what the both ends are advertising as their capabilities. This may help you determine if you have any other speed/duplex options. It the other end has the equivalent settings to those which you have, it will likely appear to be advertising only 10HD. The other end may only be capable of 10HD, or may be set to a fixed speed and duplex.

Check the errors shown by the command ifconfig eth0. If you are getting frame errors, then the line is half duplex, and you should be using the 10FD settings you are using. A correctly configured half duplex line will show collisions, with low error rates. A full duplex line should not show any errors. Track the error rates, as the counts are quite sticky.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.