Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

download the latest vmlinuz and initrd from

http://archive.ubuntu.com/ubuntu/dists/precise/main/installer-amd64/current/images/hd-media/

I put the ubuntu-12.04.1-server-amd64.iso to the /software (in my usb disk)

and put the vmlinuz and the initrd files to the / (in my usb disk)

the menu.lst for grub:

title Install UBUNTU SERVER 12.04 64BIT
root
kernel /vmlinuz boot=install iso-scan/filename=/software/ubuntu-12.04.1-server-amd64.iso ro quiet
initrd /initrd.gz

I have install ubuntu server 11.10 successfully with grub for dos,but in ubuntu server 12.04, there are some wrongs:

I have boot it,and choose the language,when I click "next", it was detecting devices, then got a wrong: Can't find any ISO file to install

share|improve this question
2  
Why this instead of the trouble free non hardcore way of using the liveusb? –  Uri Herrera Oct 18 '12 at 6:41
    
If you downloaded the kernel/initrd from installer-amd64 why do you think you need the iso? Why do you think you need the boot=install, and iso-scan options? I don't really understand what you are trying to do here. –  Zoredache Oct 18 '12 at 8:12

1 Answer 1

grub4dos

This used to work for grub4dos (e.g. hiren's boot cd):

title Ubuntu server 12.04.1 (GNOME 64-bit)
find --set-root /ubuntu-12.04.1-server-amd64.iso
map /ubuntu-12.04.1-server-amd64.iso (0xff)
map --hook
root (0xff)
kernel /install/vmlinuz  file=/cdrom/preseed/ubuntu-server.seed quiet --
initrd /install/initrd.gz

Note that this method is not for grub2. Kernel line has been found in the .iso archive (boot/grub/grub.cfg)

grub2

Follow the instructions from here: https://help.ubuntu.com/community/Grub2/ISOBoot

liveusb

An alternative solution: You may easily create a live ubuntu usb using the programs:

share|improve this answer
    
Thank you for your answer,But this method is only for desktop version, not for ubuntu server 12.04 –  wurong Oct 18 '12 at 7:53
    
Maybe this answer will help? askubuntu.com/a/126503/5538 –  medigeek Oct 18 '12 at 10:39
    
@wurong I've changed the grub4dos solution, please try it. –  medigeek Oct 18 '12 at 13:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.