Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've been trying for days to get this working, and everywhere I look online it seems no one has a definitive answer, so here is the run down:

I have an external drive attached to my ubuntu 12.04 machine, "nicholas-desktop." I have the entire drive shared over the network via SAMBA. If I try to access the drive from windows 7 by using "\nicholas-desktop" it fails saying it cannot locate "nicholas-desktop." However, if I use the current IP address assigned to my machine by my router's DHCP server by typing "\192.168.2.XXX" I have no problems accessing the share. if I try to ping my ubuntu machine's hostname from windows it fails.

The same happens if I try to ping my windows machine, "nicholas-laptop" from my ubuntu machine. Again, if I use either machine's assigned IP address it works fine. Can someone please help me get this working? I don't want any workarounds like setting a static IP, or DHCP reservation, I want to be able to resolve hostnames from both sides. I have tried enabling SAMBA'a WINS server so I could resolve the hostnames using netBIOS, however that didn't work either, I may have made a mistake setting it up though.

share|improve this question
I think if your settings are perfectly then you can find shared external drive connected with network in network places in Windows 7. – K.K Patel Oct 18 '12 at 4:16
@K.KPatel No, my ubuntu machine won't show up in network places because windows 7 cannot resolve it's host name. – user98398 Oct 18 '12 at 11:13
install system-config-samba tool by sudo apt-get system-config-samba in terminal and re-config samba perfectly – K.K Patel Oct 18 '12 at 11:59
@K.KPatel Yes, I already have that installed, you're not helping me any. I need to know why I cannot resolve my ubuntu machine's hostname from windows, and how to fix it. – user98398 Oct 18 '12 at 23:25
Check the netmask on the windows and ubuntu and router. There may be differences. – Pavel Popov Jan 29 '13 at 17:22

Windows Live Signin Assistant can cause that problem. I'd found it on Google, deleted it, and problem solved. Now I'm having it again on a new laptop running Ubuntu. Can access shares on the Windoze machine from Ubuntu, but not the reverse.

I'm thinking a myriad of Windoze updates reinstated the problem, but I don't know yet. The Windows Signin Assistant is gone.

share|improve this answer

This seems to be completely missed. Resolving IP addresses to hostnames is done via DNS. Run a DNS server and your problem will be resolved.

share|improve this answer

Hi a couple of thoughts,

  1. you don't need name for windows share to access. \\<desktop_ip_address>\nicholas_share works just as fine.
  2. as other pointed out, you don't have a DNS server to resolve name to IP. If your router acts as a DNS server, since it does DHCP, check if it has any options to add names to IPs, or register host names on DHCP. It all depends on the router.
  3. how do you keep the current IP for the desktop. If the desktop acts as a server, then it should have a reserved lease IP address or a static IP address. Once a name is cached to the IP, sometimes it remains cached, and when the IP changes, wondrous things can happen.
  4. Have you checked that your windows has network discovery enabled for the home network? It should otherwise windows smb client acts weird and quirky.
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.