Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

What is says in the topic: there's a Wireless N access point to which I'd like to connect using the 5 GHz band exclusively. How does one accomplish this? Using the directive band=a in the connection configuration file in /etc/NetworkManager/system-connections doesn't seem to affect anything (/var/log/syslog still shows attempts by wpa_supplicant to connect using the 2.4 GHz band), and running iwconfig wlan0 freq 5G per this question results in the following error:

Error for wireless request "Set Frequency" (8B04) :
    SET failed on device wlan0 ; Invalid argument.

[Edit] I'm hoping the answer won't depend on the hardware in use, but here's some information about the hardware, just in case:

System is an Asus ZenBook Prime UX31A-DB51, running Ubuntu 12.04.

lspci output:

00:00.0 Host bridge: Intel Corporation Ivy Bridge DRAM Controller (rev 09)
00:02.0 VGA compatible controller: Intel Corporation Ivy Bridge Graphics Controller (rev 09)
00:04.0 Signal processing controller: Intel Corporation Device 0153 (rev 09)
00:14.0 USB controller: Intel Corporation Panther Point USB xHCI Host Controller (rev 04)
00:16.0 Communication controller: Intel Corporation Panther Point MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation Panther Point USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation Panther Point High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation Panther Point PCI Express Root Port 1 (rev c4)
00:1c.1 PCI bridge: Intel Corporation Panther Point PCI Express Root Port 2 (rev c4)
00:1d.0 USB controller: Intel Corporation Panther Point USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation Panther Point LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation Panther Point 6 port SATA Controller [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation Panther Point SMBus Controller (rev 04)
00:1f.6 Signal processing controller: Intel Corporation Panther Point Thermal Management Controller (rev 04)
02:00.0 Network controller: Intel Corporation Centrino Advanced-N 6235 (rev 24)

The driver for the wireless interface is iwlwifi.

share|improve this question
    
This looks like something hardware specific, so what wireless card do you have, and what drivers do you have for it? –  hexafraction Oct 17 '12 at 22:44
    
I'ld be looking at going around this one at setting the channel number instead to something only found in the 5Ghz band: en.wikipedia.org/wiki/… –  hbdgaf Oct 18 '12 at 8:29

1 Answer 1

up vote 1 down vote accepted

Using iwlwifi on 12.10,

iwconfig wlan0 channel 36

or

iwconfig wlan0 freq 5.18G

works

You MUST specify the channel (or exact corresponding frequency). Specfifying the frequency band (iow. just "5G") does not work.

Note that some dual-band/dual-radio access points (maybe only those of the "enterprise" category) can/should use "band steering" (aka. "frequency handoff"): the AP detects 5G-able clients and disconnect them from the 2.4G band to force them off to the 5G band. It may takes some time for this "trick" to take place, though.

share|improve this answer
    
of course, specify the channel/frequency that you have configured on your AP ;-) –  Cédric D. Feb 26 '13 at 7:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.