Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using ubuntu 12.04LTS on my vaio laptop and I am in a situation that I have to use two different VPNs to have a good internet access and I don't know how to achieve that.because when I click on a VPN to connect(through Networks->VPN Connections), current connected VPN will be disconnected first.

share|improve this question
    
Are you trying to multiplex? Wouldn't the bottleneck be your last-mile connection to your (physical) ISP, if you have a good VPN service? –  hexafraction Oct 17 '12 at 22:36
    
No, I'm just a user wants to have two connected VPNs together to have access both resources simultaneously. –  Peyman Mahdian Oct 17 '12 at 22:47
add comment

1 Answer 1

As far as I know, you can only run one VPN using Network Manager. I have to run two VPNs (openvpn) at work, too. I connect to the first with Network Manager and to the second using a terminal. I have installed the byobu terminal emulator for this, because you can detach the vpn session from it (using the F6 key).

share|improve this answer
    
Could you please add more details about your answer,specially about byobu terminal emulator. –  Peyman Mahdian Oct 18 '12 at 14:51
    
You can use any terminal, e.g. the standard gnome terminal (just type "terminal" in the Dash to find it). To start a openvpn session, navigate to the directory containing your vpn certificates, then type "sudo openvpn <your_vpn>". You will be asked to type first your sudo-password and then your vpn username and password. If you have done everything right, the vpn session will be running until you stop it by pressing ctrl+c in the terminal window. I only prefer byobu because you can close the terminal without stopping the vpn process. It can be installed from Ubuntu Software Center. –  speter Oct 18 '12 at 22:17
    
,I've done what you said and I get this----> sudo: openvpn: command not found –  Peyman Mahdian Oct 18 '12 at 22:34
    
Sounds loke you haven't installed openvpn yet. To do so, open a terminal, type "sudo apt-get update && sudo apt-get install openvpn". After the installation, try again. –  speter Oct 18 '12 at 22:45
    
What is <your_vpn>, because when I write my VPN name in VPN Connections, I get this --> Options error: In [CMD-LINE]:1: Error opening configuration file: XXX –  Peyman Mahdian Oct 19 '12 at 14:58
show 3 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.