Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried the answers other similar queuest in Ask Ubuntu, but didn't get it to work.

I reboot Ubuntu 12.04. I remote in using SSH, and do /usr/lib/vino/vino-server to start VNC service.

UltraVNC client reports: Failed to connect to server!

But if I login at the Ubuntu computer and try UltraVNC again, it works.

share|improve this question
add comment

2 Answers 2

I also had this issue. I tried user1689961's answer but got a connection refused. When I added the -allow <ip address of client> option, it worked.

The full command:

sudo x11vnc -safer -localhost -once -nopw -auth /var/run/lightdm/root/:0 -display :0 -allow <ip address>
share|improve this answer
add comment

This is a great guide.

https://help.ubuntu.com/community/VNC/Servers

Specifically, this command worked for me:

sudo x11vnc -safer -localhost -once -nopw -auth /var/run/lightdm/root/:0 -display :0
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.