Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Irritatingly, when I click a link in an application (I use Quassel), firefox opens the default start page.

I have a somewhat non-standard configuration setup. I am using a nightly build of firefox, where the binary is located at /opt/nightly/firefox. I have a symbolic link from /usr/bin/firefox -> /opt/nightly/firefox. I have Ubuntu 11.04, using Gnome with Docky. My docky panel has a firefox icon on the panel that correctly uses the firefox that I want, but when I click on a link in an application such as Quassel, it only opens with the default start page, rather than the link I want to navigate to. Also, it opens in a new window, rather than creating a new tab in my existing session.

I've tried playing with the gconf-editor, and the gconftool-2 -R /desktop/gnome/url-handlers command gives me:

 /desktop/gnome/url-handlers/unknown:
  command = firefox "%s"
  needs_terminal = false
 /desktop/gnome/url-handlers/net:
  command = totem "%s"
  needs_terminal = false
  enabled = true
 /desktop/gnome/url-handlers/msnim:
  command = purple-url-handler "%s"
  needs_terminal = false
  enabled = true
 /desktop/gnome/url-handlers/chrome:
  command = firefox "%s"
  needs_terminal = false
  enabled = true
 /desktop/gnome/url-handlers/rtsp:
  command = totem "%s"
  needs_terminal = false
  enabled = true
 /desktop/gnome/url-handlers/cdda:
  command = sound-juicer %s
  needs_terminal = false
  enabled = true
 /desktop/gnome/url-handlers/ftp:
  command = firefox "%s"
  needs_terminal = false
  enabled = true
 /desktop/gnome/url-handlers/ut:
  command = /usr/share/ubuntu-tweak/uturl "%s"
  needs_terminal = false
  enabled = true
 /desktop/gnome/url-handlers/uvox:
  command = totem "%s"
  needs_terminal = false
  enabled = true
 /desktop/gnome/url-handlers/h323:
  command = ekiga -c %s
  needs_terminal = false
  enabled = true
 /desktop/gnome/url-handlers/about:
  command = firefox "%s"
  needs_terminal = false
 /desktop/gnome/url-handlers/mailto:
  command = thunderbird %s
  needs_terminal = false
  enabled = true
 /desktop/gnome/url-handlers/sip:
  command = purple-url-handler "%s"
  needs_terminal = false
  enabled = true
 /desktop/gnome/url-handlers/xmpp:
  command = purple-url-handler "%s"
  needs_terminal = false
  enabled = true
 /desktop/gnome/url-handlers/vnc:
  command = vinagre %s
  needs_terminal = false
  enabled = true
 /desktop/gnome/url-handlers/http:
  command = firefox "%s"
  needs_terminal = false
  enabled = true
 /desktop/gnome/url-handlers/mmsh:
  command = totem "%s"
  needs_terminal = false
  enabled = true
 /desktop/gnome/url-handlers/rtp:
  command = totem "%s"
  needs_terminal = false
  enabled = true
 /desktop/gnome/url-handlers/mms:
  command = totem "%s"
  needs_terminal = false
  enabled = true
 /desktop/gnome/url-handlers/irc:
  command = purple-url-handler "%s"
  needs_terminal = false
  enabled = true
 /desktop/gnome/url-handlers/pnm:
  command = totem "%s"
  needs_terminal = false
  enabled = true
 /desktop/gnome/url-handlers/callto:
  command = gnomemeeting -c %s
  needs_terminal = false
  enabled = true
 /desktop/gnome/url-handlers/https:
  command = firefox "%s"
  needs_terminal = false
  enabled = true
 /desktop/gnome/url-handlers/gg:
  command = purple-url-handler "%s"
  needs_terminal = false
  enabled = true
 /desktop/gnome/url-handlers/trash:
  command = nautilus "%s"
  needs_terminal = false
  enabled = true
 /desktop/gnome/url-handlers/ghelp:
  command = gnome-help "%s"
  needs_terminal = false
  enabled = true
 /desktop/gnome/url-handlers/icq:
  command = purple-url-handler "%s"
  needs_terminal = false
  enabled = true
 /desktop/gnome/url-handlers/ymsgr:
  command = purple-url-handler "%s"
  needs_terminal = false
  enabled = true
 /desktop/gnome/url-handlers/icy:
  command = totem "%s"
  needs_terminal = false
  enabled = true
 /desktop/gnome/url-handlers/magnet:
  command = transmission '%s'
  needs_terminal = false
  enabled = true
 /desktop/gnome/url-handlers/note:
  command = tomboy --open-note '%s'
  enabled = true
 /desktop/gnome/url-handlers/info:
  command = gnome-help "%s"
  needs_terminal = false
  enabled = true
 /desktop/gnome/url-handlers/apt:
  command = apturl "%s"
  needs_terminal = false
  enabled = true
 /desktop/gnome/url-handlers/man:
  command = gnome-help "%s"
  needs_terminal = false
  enabled = true
 /desktop/gnome/url-handlers/icyx:
  command = totem "%s"
  needs_terminal = false
  enabled = true
 /desktop/gnome/url-handlers/webcal:
  command = /usr/lib/evolution-webcal/evolution-webcal %s
  need-terminal = false
  enabled = true
 /desktop/gnome/url-handlers/aim:
  command = purple-url-handler "%s"
  needs_terminal = false
  enabled = true
share|improve this question

1 Answer 1

I had the exact same problem, here is how you can fix it:

  1. Open with your editor the file ~/.local/share/applications/firefox.desktop
  2. Locate the line with Exec: firefox (line 149, in my case)
  3. Append %u to it, so the url will be passed along: Exec: firefox %u
  4. Test it with xdg-open http://askubuntu.com

And that's it, it should work like expected now.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.