Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I did this very clever decision to set windows 7 bootloader to ubuntu. Now I cannot boot back to windows. If I try to boot via grub it shows the windows bootloader for half a second and goes back to grub. Also the safemode of windows ceased to work, so I cannot go back and change the settings. I am totally screwed here and would not want to install the OS (both of them) again...

share|improve this question
    
have you tried sudo update-grub? –  Marco Scannadinari Oct 17 '12 at 17:48

1 Answer 1

I have had similar issues before. the solution was to grab a Windows install CD, and to boot to it.

choose your language and press next.

click "repair your computer"

follow the on screen instructions and it will try to locate issues and repair them.

I have had similar issues when setting up dual boot, or expanding my win7 partition. good luck!

share|improve this answer
    
I tried that today, it made a system restore, but it did not affect the bootloader sequence, still keeps booting straight to Grub.... I fear i have to make a clean install, only because i clicked on a box...(they should have put some warning in cases like this). But thanks for the advice, i also tried to enter command prompt and set the bootloader to default but did not succeed –  noob Oct 21 '12 at 20:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.