Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using 12.04 LTS amd64 as a KVM host + desktop. I have a Windows 7 ultimate 64bit guest on this host. The installation worked perfect with the default (VNC display) settings. Everything also works very well over a RDP session (using rdesktop) to the box, including sound and video. Netflix, however, can detect somehow that I'm on a remote desktop session so it fails at the "buffering" stage to launch the movie. I wanted to try out SPICE as a workaround for this, but when I switch the guest display over to SPICE it fails to launch with :

Error starting domain: unsupported configuration: spicevmc not supported in this QEMU binary

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/asyncjob.py", line 45, in cb_wrapper
    callback(asyncjob, *args, **kwargs)
  File "/usr/share/virt-manager/virtManager/asyncjob.py", line 66, in tmpcb
    callback(*args, **kwargs)
  File "/usr/share/virt-manager/virtManager/domain.py", line 1120, in startup
    self._backend.create()
  File "/usr/lib/python2.7/dist-packages/libvirt.py", line 551, in create
    if ret == -1: raise libvirtError ('virDomainCreate() failed', dom=self)
libvirtError: unsupported configuration: spicevmc not supported in this QEMU binary

How can I fix this?

share|improve this question

3 Answers 3

You'll have to install the following packages to use SPICE in Ubuntu 12.04:

Then reload the Libvirt service:

sudo service libvirt-bin restart
share|improve this answer

I found the answer here : https://launchpad.net/~bderzhavets/+archive/lib-usbredir87

Thank you Boris Derzhavets!

share|improve this answer
3  
Can you please post the answer from that link in your response? –  Kyle Macey Nov 1 '12 at 17:31

Despite what many posts say, qemu-system-x86_64-spice (v1.0.50) works fine on Ubuntu 12.04 without any special PPA's and such, just a:

apt-get install qemu-kvm-spice

Getting it running on a Windows VM, required 3 boots, each incrementally installing more drivers. I copied the relevant command-line parameters off this Gentoo thread: http://forums.gentoo.org/viewtopic-t-949642-start-0.html - and downloaded the latest versions of the guest-tools and viewers. The SPICE qemu binary also complained about a missing firmware file, which I downloaded from https://germa939-limbopc.googlecode.com/git-history/371c259a4d8fa8e6682b4dc87d7e85a440f7c12a/assets/roms/kvmvapic.bin and placed in /usr/share/kvm; I'm not sure what it does or if it was necessary.

I also ran into a black-screen problem on first connection after installing the spice guest tools, but giving it a good few minutes to boot up, (it's very slow before it goes active) - it worked. (I doubt logging in to the VM with Terminal Service Remote Desktop triggered everything, but it at least confirmed that the VM booted properly.)

SPICE is great - it makes the VM use around 60% less CPU and offers a true native experience, albeit it uses between 100kbps and 80Mbps depending on what's happening on the screen, although you will probably prefer it above Terminal Services and VNC if you have 5-10Mbps available downstream. A huge plus is the shared clipboard.

The viewer seems to be universally in a package called "virt-viewer", and the actual command on linux being "remote-viewer", requiring a full "spice://ip:port" URL.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.