Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have changed my source to local server. I'm using Ubuntu 12.10.

When I type apt-cache search in terminal, it shows nothing.

When I install lightread it shows Unable to locate package lightread.

When I install lightread manually by python. It shows

python '/home/peng/Downloads/quickly_trunk/setup.py' 
Traceback (most recent call last):
File "/home/peng/Downloads/quickly_trunk/setup.py", line 93, in <module>
data_files=[('share/icons/hicolor/128x128/apps', ['data/media/lightread.png'])]
File "/usr/lib/python2.7/dist-packages/DistUtilsExtra/auto.py", line 71, in setup
src_mark(src, 'setup.py')
File "/usr/lib/python2.7/dist-packages/DistUtilsExtra/auto.py", line 527, in src_mark
src.remove(path)
KeyError: 'setup.py'

How to solve the problem?

share|improve this question
add comment

3 Answers 3

up vote 7 down vote accepted

Lightread is a totally awesome offline Google Reader. With beautiful design and incredible Ubuntu integration, Lightread is the best RSS reader for Linux.

Install Lightread in ubuntu

ppa:cooperjona/lightread Launchpad logo (Click here for instructions on using PPAs.)

Open the terminal and run the following commands (for ubuntu 12.04 , 12.10 , 13.04)

sudo add-apt-repository ppa:cooperjona/lightread
sudo apt-get update
sudo apt-get install lightread
share|improve this answer
add comment

Bug is already marked as fixed: https://bugs.launchpad.net/lightread/+bug/1065853 So you should be able install Lightread via ppa.

share|improve this answer
add comment

There are no packages available for Quantal yet: https://bugs.launchpad.net/lightread/+bug/1065853

The setup.py script in the directory is not for installation it's for creating the deb package.

Easy way to install it is to check out the source from launchpad and then create your own package on quantal using quickly:

bzr branch lp:lightread
cd lightread
quickly package --extras
sudo dpkg -i ../lighread-`version`.deb

I don't know what the version quickly will spit out, so you'll have to check. You may need to install the bzr and quickly packages to download and install the source this way. However, you may have already downloaded the source so you can just try running the quickly package --extras command in the downloaded source (quickly_trunk) directory.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.