Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm running Ubuntu 11.10 and I keep facing this error message in a dialog box, right after I boot up my computer (already in graphical mode):

Failed to apply network settings

org.freedesktop.DBus.Error.Spawn.PermissionsInvalid: The permission of the setuid helper is not correct

You might not be able to connect to the Bluetooth network via this machine

Worth mentioning is that I did accept some updates in the update manager prior to this error showing up.

The symptoms following the error message is that I can't find my other hard drives on the computer.

I seem to have proper Internet connection, though - contrary to what one would think, regarding the error message title.

Also I can't shut down the computer. I can log out, but then nothing happens when I choose the "Shut down" menu option (I simply have to long-press the power button for 8 seconds or so).

So! Do you guys know What the error message means? And more importantly; how I can fix the underlying fault? I have google-d the issue but with no further success.

Cheers, dbm

share|improve this question
up vote 3 down vote accepted

It seems like I, by mistake - naturally (*blushing*), did interrupt my update process. The reason why I think so is that I tried to sudo apt-get on some other packages when I got the following error message in the terminal:

E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.

Following the very instructions given in the message (i.e. issuing the sudo dpkg --configure -a command) solved my problem. The error messages, "Failed to apply..." and "E: dpkg was interrupted..." are gone and my system is back to a happy state, as am I.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.