Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just received my Pandaboard ES (rev B) and I am having trouble after installing ubuntu-omap4-addons.

Once I copied the image ubuntu-12.04-preinstalled-desktop-armhf+omap4.img on my sd card and boot the pandaboard with it, I run the following commands:

sudo add-apt-repository ppa:tiomap-dev/release
sudo apt-get update
sudo apt-get dist-upgrade
sudo apt-get install ubuntu-omap4-extras

At the end of the installation of ubuntu-omap4-extras, Ubuntu tells me that a problem occurs when the console displays:

ldconfig deferred processing now taking place

Clicking on "report the problem" tell me that the problem concerns pvr-omap4-dkms. I read somewhere that this can happen and it is better to reinstall pvr-omap4-dkms. Which I am doing by running:

sudo apt-get install --reinstall pvr-omap4-dkms

I reboot.

Then the board has sometimes difficulties to start Ubuntu: it freezes during the loading page, only action I can do is unplugging the board to start it again. Some other times, Ubuntu load successfully but then freeze at another random time, in the range 20 - 40 minutes.

I searched on internet for similar bug and found this: https://bugs.launchpad.net/ubuntu/+source/linux-ti-omap4/+bug/971091

So I typed this in:

update-rc.d ondemand disable
apt-get -y install cpufrequtils
echo 'ENABLE="true"
GOVERNOR="performance"
MAX_SPEED="0"
MIN_SPEED="0"' > /etc/default/cpufrequtils
cpufreq-set -r -g performance
reboot

But it doesn't seems to fix the bug.

Another detail: on startup, before the loading screen of Ubuntu (when there is the two penguins displayed :)), it shows this:

[0.297271] CPU1: Unknown IPI message 0x1
[0.308990] omap_hwmod: mcpdm: _wait_target_ready error: -16
[0.354705] omap_mux_get_by_name: Could not find signal uart1_cts.uart1_cts
[0.354766] omap_hwmod_mux_init: Could not allocate device mux entry
[2.107086] thermal_get_slope:Getting slope is not supported for domain gpu
[2.107116] thermal_get_offset:Getting offset is not supported for domain gpu
[2.107299] stm_fw: vendor driver stm_ti1.0 registered
[8.725555] OMAPRPC: Registration of OMAPRPC rpmsg service returned 0! debug=0

Any idea what can be wrong? I am not that good with Ubuntu so any help will be appreciated.

Cheers!

Meach

share|improve this question
add comment

2 Answers 2

I've also experienced the same symptoms but cured with disabling ondemand frequency scaling on my panda ES.

As Xavier replied already to some guy in their October release announcement thread, I did the remedy as followings.

Edit file: /etc/init.d/ondemand Comment line:

echo -n ondemand > $CPUFREQ

I've, also, running test with panda board and seems to be no problem with proper cooling. Without cooling such as fan or heat sink, 11.10 oneiric with TI ppa enhancement also failed some times on this board.

I know omap4460 use lower clock frequency than omap4430 due to chip revision issue in boot code. This problem should be related to maximum clocks allowed for safe operation, I think.

share|improve this answer
    
After few hours of running on panda, freezing occurs once again.According to Xavier, they will focus on November with this issue, so stay tuned. –  SeongHan Kim Nov 1 '12 at 14:00
    
panda ES rev B1, also, facing freezing or lockup after an hour or more, tough I've limit max scaling freq. to 920Mhz. Are they set highest possible clock for IVA-HD & others which is not safe on older boards? –  SeongHan Kim Nov 1 '12 at 17:54
    
My panda rev A2 also suffer with 'cpufreq-set --max 800Mhz' on 12.04. While 11.10 runs at least several hours w/o any freezing. Runs very well topped at 800Mhz w/o any cooling. –  SeongHan Kim Nov 1 '12 at 18:05
add comment

Ok I just fixed my system which had the same problem. You aren't using the proper U-boot version and/or did not have the settings that I added in the previous post. Yes the previous post was supposed to be an answer/question at the same time. To fix make sure that you do this:

sudo gedit /boot/boot.script

then change the values that i showed in the previous post One important remark concerning bootargs when upgrading to TI kernel: Please replace "vram=40M mem=456M@0x80000000 mem=512M@0xA0000000" or any vram or split mem settings with: "mem=1G@0x80000000"

We advise following bootargs: ro elevator=noop console=ttyO2,115200n8 mem=1G@0x80000000 root=(your root) fixrtc splash

next is to run "sudo /usr/sbin/flash-kernel --update-bootloader"

Also make sure that you have the correct U-Boot version

running "dpkg -l | grep u-boot-linaro-omap4-panda" in terminal should yield "ii u-boot-linaro-omap4-panda 2012.04.2+6514+45+201207191704~precise1 U-Boot bootloader binary for the TI OMAP4 Panda board"

if not then the quick fix would be to make sure the ppa is selected and then to run in terminal: "sudo apt-get install u-boot-linaro-omap4-panda"

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.