Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to get Subclipse working in Eclipse Galeilo, and to do that I have to install the JavaHL library.

I installed the library using sudo apt-get install libsvn-java, but the eclipse.ini file has to be modified to take in the new library as an argument.

First change to the ini file was -Djava.library.path=/usr/lib/jni/, which produced the errors
"no libsvnjavahl-1 in java.library.path"
"incompatible javahl library loaded. 1.3.x or later required."
according to the install printout, version 1.6.12 was installed.

So, I added to the file path above, and produced the following errors:
"no libsvnjavahl-1 in java.library.path"
"no svnjavahl-1 in java.library.path"
"no svnjavahl in java.library.path"

What's going on here?

share|improve this question
up vote 3 down vote accepted

are you installing eclipse from ubuntu repository? or download from eclipse?

IMHO you need install eclipse manually.

first you install subversion :

sudo apt-get install subversion

if you want to install subversion plugin for eclipse, you can install using menu Help -> Install New Software choose Helios or Galileo :

Eclipse Helios

choose Collaboration and select Subversive :


share|improve this answer
Thanks for the help. I basically had to reinstall eclipse to get it working, but you got me on the right track – Jason Jan 5 '11 at 21:15

Subversive? Not a good option, the problem is that version 1.7 or later of JavaHL is required, and the user is correct that libsvn-java only includes 1.6.x. Ubuntu needs to update this library.

share|improve this answer

Install svn from WANdisco - worked for me. Small explanation with solution:

Script to run (found in the post above too), which will install the subversive and libsvn-java 1.7

And (as specified in the question), add the following line in eclipse.ini


share|improve this answer
Matyas has the key points. Get 1.7 and future svn from wandisco's repository and instruct eclipse on where to find the library. Otherwise, you'll have 1.7 but won't be able to find JavaHL. Very nice work. – Peter Kahn Jun 19 '12 at 20:02

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.