Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've installed iBus and ibus-mozc, an input method engine of Japanese from the repository on Kubuntu 12.04. Then attempted to enable mozc from Preference > "Input Method" tab > "Select Input Method" combo box. However, there is no choice to select, so I couldn't enable mozc.

I also tried ibus-anthy, another legacy Japanese input method, but the situation was the same and I couldn't use anthy.

Same problem is also occuring in openSUSE 12.1, so I don't think this is distribution-specific problem.

In addition, this trouble also happened when I installed ibus-pynin, so this is not Japanese-specific problem.

Any idea to find the cause of this trouble?

share|improve this question
1  
maybe restart i-bus? –  zeitue Oct 17 '12 at 6:54
    
Nothing changed unfortunately... It always happens. –  phanect Oct 18 '12 at 4:35
    
Rebooting: primitive but fixed the problem for me. –  Nicolas Raoul May 14 '13 at 9:47
    
Unfortunately rebooting did nothing when I was trying to solve above problem... Currently (on Kubuntu 13.04) this problem is not happening, so rebooting may solve the problem on 13.04. –  phanect May 16 '13 at 12:37

2 Answers 2

up vote 1 down vote accepted

I had the same problem and resolved it by also installing ibus-m17n from the package manager. I know this post is a little old but hope this helps someone.

I'm using Linux Mint 14.

share|improve this answer
    
Thank you! I solved this problem by installing Kubuntu with Japanese interface which install ibus by default (this problem happens when I install with English interface) but next time I will check about that. It is messy to take back from Japanese interface to English interface (^^; –  phanect Dec 6 '12 at 2:13
    
@phanect: As you can see even long afte you asked your question, the folks here are still looking for answers for you. This is because your question is still open. If you have resolved it, you should answer your own question and mark it as accepted. This will help others know what the solution is if they experience the same or a similar issue. Thank you. –  Stephen Myall Dec 6 '12 at 10:42
    
@StephenMyall This time I solved this problem by installing Kubuntu with Japanese interface, but that is just a workaround for me. I want to install with English interface because I usually use in English interface and changing interface language is a little bit messy, so the problem was not solved this time. But anyway thanks for your advise :) –  phanect Dec 7 '12 at 14:25
    
Install ibus-m17n doesn't work, I use Mint KDE 16 –  Ooker Apr 4 at 16:32

On Linux Mint 14, restarting ibus helped! I had also ibus, ibus-m17n and ibus-anthy installed from synaptics.

share|improve this answer
1  
Could you please elaborate how this solves the OP question? –  Braiam Aug 7 '13 at 22:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.