Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Prior to a recent glytch where I lost some of my custom settings, Nautilus would open directories and display the name-column wide enough to show the longest filename on display. It did it dynamically; If I renamed a file to a longer or shorter name, the column was automatically adjusted to the new width..

It's not doing that now, and I have no idea how to get this function back..


UPDATE
The OS is: 10.04. and Nautilus is: 2.30.1

UPDATE
I hadn't mentioned it, but I am talking about the List view... I have been fossicing around in the GConf Editpr and came across a setting for Compact View which does exactly what I am referring to... but it only effects the Compact View... that setting is:

  • gconf-editor /apps/nautilus/compact_view/all_columns_have_same_width

...but I can't find the setting for List View... I know the capability exists, because I've been using it until only a few days ago, when my system got hung up...

share|improve this question
    
You sure it was not a different file manager? Cuz I even found bug regarding the fixed column width. –  danizmax Jan 5 '11 at 19:54
    
It was definitely Nautilus, I use it almost exclusively... I must say that I don't recall ever setting something ON specifically (but that doesn't mean I didn't... I've been using Ubuntu for less than 4 months, and endless new situations and setting become a bit of a blurr at times... but it was working! .. and I liked it! .... Maybe the bug just "bugged" ON and gave me access for a few weeks... but I'm just wild guessing now... –  Peter.O Jan 5 '11 at 21:44
    
I'm getting this behaviour from nautilus 3.4.2 on ubuntu 12.10. It's annoying me to no end. I wish I knew how to turn it off :) –  Li Lo Oct 30 '12 at 9:42

3 Answers 3

It is possible to set list view as default, and also select desired zoom level with:

nautilus-file-management-properties
share|improve this answer
1  
Thanks Aputsiaq, but all those settings. and more, are available via GConf Editor, and nothing seems to do the trick. The cmmand to take you directly to the Nautilus section is similar to the one in my question "update". it is: gconf-editor /apps/nautilus –  Peter.O Jan 5 '11 at 22:07
up vote 0 down vote accepted

It looks like its time to wind this question up. It seems that this issue may be bug-related, so all bets are off on a "normal" outcome (until the bug is resolved)..

The happy offshoot of this has been that since I found out that the same feature functions properly in Compact mode, I've started using that mode instead... and for when I actually want to see the full details of List view, it's a quick as Ctrl+2 and Ctrl+3 .. Easy!... so it seems that I've now got the best of both worlds; more files on view (Compact), and all the details (List)... :)

share|improve this answer

To make column automatically adjust to the widest item, point at this column's resize area (left of the column title, where the arrow turns into left and right arrows), and double-click. To disable auto adjust, just do this once again.

share|improve this answer
    
I have just tested Nautilus 3.4.2 in 12.04. It behaves approximately as you have described, though double-clicking a second time does not disable the auto-adjust; maybe it does in later versions. That said, the question is about Nautilus 2.30.1 in 10.04, where it does not work. It is good to know that later versions of Nautilus can do it. –  Peter.O Jan 2 '13 at 3:10
    
Sorry, I've forgot to add: I was testing in Ubuntu 11.10, Nautilus 3.2.1. Both features work as described. If disabling auto-adjust doesn't work in 12.04, it's probably a regression (can't check it right now). –  Alex Shalimov Jan 2 '13 at 6:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.