Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to use ZFS (zfsforlinux stable) on Ubuntu 12.04 x86_64 Server. I enabled the PPA, and apt-get install ubuntu-zfs works successfully. However, no zfs module is created and the zpool and related commands all complain that they can't install the module.

Help!

share|improve this question

2 Answers 2

Install the pre-requisites and then do a

apt-get install --reinstall zfs-dkms

share|improve this answer
2  
Welcome to Ask Ubuntu! I recommend editing this answer to explain in greater detail what the prerequisites are and how to install them. –  Eliah Kagan Jan 24 '13 at 4:24

If you do not have build-essentials and kernel header installed the DKMS build steps will fail during the install of ubuntu-zfs. Were any error messages written to the console?

I ran into a similar problem. I attempted to install ubuntu-zfs BEFORE installing build-essentials and the kernel headers. That left a bit of a mess. Removing ubuntu-zfs does not remove all of it's dependencies. I had to:

dpkg --list | grep zfs

and

dpkg --list | grep spl

and track down the packages that were not removed by apt-get purge ubuntu-zfs.

After cleaning things up and installing the correct pre-requisites the install worked but still failed to correctly configure the modules to load.

share|improve this answer
    
I had the same issue. To be a bit more clear do the following: apt-get remove --purge ubuntu-zfs zfs-dkms zfsutils spl spl-dkms libzfs1 dkms Then, REBOOT. Then, do: apt-get install linux-headers-generic build-essential Then, do: apt-get install ubuntu-zfs –  Tony Maro May 15 '13 at 17:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.