Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Could you guys suggest why a2ensite doesn't create symlink in my case even though it says site was enabled ?

I have Ubuntu 12.04.1 LTS and Apache 2.2.22

I created /etc/apache2/sites-available/testphplocal.com. Here is my console log

root@ubuntu:/# sudo a2ensite testphplocal.com 
Enabling site testphplocal.com.
To activate the new configuration, you need to run:
  service apache2 reload
root@ubuntu:/# sudo service apache2 reload
 * Reloading web server config apache2                                                                                                                                                 apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName
                                                                                                                                                                                [ OK ]
root@ubuntu:/# sudo /etc/init.d/apache2 restart
 * Restarting web server apache2                                                                                                                                                       apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName
 ... waiting apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName

No symlink created in /etc/apache2/sites-enabled/. If I open http://phptestlocal.com/ it gives me Internal Server Error but nothing added to errors.log

share|improve this question
    
Is there really no symlink? What does ls /etc/apache2/sites-enabled/ -l say? I think there's a problem somewhere else. –  phoibos Oct 16 '12 at 19:22
    
Unfortunately it works now :( –  ruslan Oct 16 '12 at 19:53
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.