Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have manually tried to install AMD Radeon HD 7470M proprietary drivers from AMD official site. But after installing when I tried to launch Catalyst Control Center, a message is shown like this:

There was a problem initializing Catalyst Control Center Linux edition.

It could be caused by the following:

No AMD graphics driver is installed, or the AMD driver is not functioning properly. Please install the AMD driver appropriate for you AMD hardware, or configure using aticonfig.

I am using Ubuntu 64-bit 12.04LTS.

share|improve this question

Your card is not supported by any driver, closed or open source.

You need to use what is working for you at the moment and wait for AMD to start supporting your card via their drivers.

share|improve this answer
here is the link to check for AMD driver availability – Boris Dec 7 '12 at 17:43

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.