Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have to do a complete unattended installation of a node with Ubuntu12.04. I have given following options in preseed file

d-i netcfg/choose_interface select eth0
d-i netcfg/disable_dhcp boolean true
d-i netcfg/dhcp_failed note
d-i netcfg/dhcp_options select Configure network manually
d-i netcfg/disable_autoconfig boolean true
d-i netcfg/use_autoconfig  boolean false
d-i netcfg/network-manager boolean false
d-i netcfg/no_default_route boolean true
d-i netcfg/enable boolean true
d-i netcfg/get_ipaddress string
d-i netcfg/get_netmask string
d-i netcfg/Confirm_static boolean true

Still d-i is asking "Continue without a default route? ", i have to say YES manullay. How can i preseed this while d-i Configure the network

Even after setting default gateway & name server still the same.

share|improve this question

Looks like you didn't define a default gateway, you need to use:

d-i netcfg/get_gateway string

Of course the ip address in the above command is just a guest, you should adjust it to the correct gateway of your network.

I can't test it, but it's very likely that you will need this too:

d-i netcfg/get_nameservers string
d-i netcfg/confirm_static boolean true

The first one will set the dns, I don't know why or if the second one is necessary but it appears in the documentation so...

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.