Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a 2nd hard drive that is used for data only, it has been formatted both in NTFS and FAT32, the system is dual booted with Windows so the Data drive is used to share data between Win and Ubuntu.

However in Ubuntu with the user account set as limited user, I cannot do anything with the files, namely create files, edit names, move them, modify etc. But I can do all that fine with the Admin account.

I've tried changing permissions, ownership, installing ntfs plugins etc. Nothing seems to work. Didn't have this problem in the old Ubuntu 10.04. I'm currently running on 12.04 LTS

Cheers

share|improve this question
1  
How do you mount your drive? If it is via /etc/fstab, please post the relevant line(s) for this drive. –  phoibos Oct 16 '12 at 10:13
    
Please most the messages from mount and post the contents of your /etc/fstab –  January Oct 16 '12 at 10:14
    
Take a look here: Mounting Windows Partitions. Install ntfs-conifg tool and enable read-write access. –  NikTh Oct 16 '12 at 10:56
    
Hi I had a line in fstab automoutning the partition on boot, have removed this but the original problem was needing the admin password to mount the partition as user. How do I get around this? –  UbuntuUser Oct 17 '12 at 15:44

2 Answers 2

Another quick solution:

  • Run 'gksu nautilus' (use 'Ctrl+alt+T' for quick access to terminal)
  • Go to the /media folder in the file system.
  • Then right click the drive, and go into properties
  • Under the permissions tab change the permissions to read/write, and make sure 'owner' and 'group' are set to "your user name" instead of "root".
  • Then click "Apply permissions to enclosed folders."

(you may have to 'sudo apt-get install nautilus')

You should be able to access the folder from your user account without root access.

share|improve this answer

Have you seen Mounting Windows Partitions from the Ubuntu community wiki?

Name: ntfs-config

Install ntfs-config package either from Ubuntu Software Center or via terminal with this command

sudo apt-get install ntfs-config

Then call it from Dash by writing ntfs config and mark the box with "Enable write support"

This should work as well for internal HDD.

NTFSConfig

Another tool you can install is a GUI program for fstab.

BE CAREFUL with this program , you can corrupt your system very easy.

Name: Storage Device Manager.

Search it by name in Ubuntu Software Center

or install it via terminal with this command

sudo apt-get install pysdm

Call it from Dash by writing Device Manager and from there you can manage, how your HDD will behavior.

pysdm

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.