Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to install ubuntu 12.04 using WUBI.exe from within windows 7. All goes well but when it restarts and installation proceeds it gives and error "No root file system defined". I have tried booting from live USB and Live CD but the same error occurs. Then i downloaded 11.10 version and booted into it using live USB but same error occurs there.

Now the thing is that i have 4 partitions on hard disk:

1- C: 147GB (with WINDOWS 7 installed)

2- D, E which i use for file storage in windows

3- G: 19GB NTFS formatted from windows

I am trying to install Ubuntu into this G drive. I want to keep my windows 7 files and installation intact. I have tried it a while ago for 11.10 and at that time it all went super smooth. I have tried rebuilding the partition table from cmd.exe in windows and i have also tried by formatting my G drive to ext3 using Easeus Partition manager in windows and then installing using wubi but wubi.exe didn't detected the partition formatted to ext3. When i ran the installation wizard from within ubuntu running through live usb, i got a window with DEVICE= /dev/sda and no type no size nothing.

Here when i choose my 320GB drive it just gives the option as in picture and when i pressed install the same error "no root file system defined". I have tried to select the new partition table option but it give me the window to create a partition by dividing 320GB whole into whatever i want. I don't proceed into that option because i think i will ruin my windows 7 stuff.

I am posting the pictures at of installation steps i have defined in the following link please have a look.

enter image description here enter image description here

Please help me!

share|improve this question
    
askubuntu.com/questions/135705/… –  user98893 Oct 19 '12 at 16:22
1  
possible duplicate of WUBI - No root system file defined –  bcbc May 9 '13 at 21:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.