Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

after installing ubuntu 12.04 i had the problem that i had a black screen directly after rebooting. So i used the grub option "nomodeset" to get an screen. I installed the recommended flgrx drivers and disabled the nomodeset option. Still can't use my graphics card. Also the option "xforcevesa" does not solve my problem.

I would need 3D enabled because i need blender to work. I hope someone can help my to get my ATI Graphics Card running. I don't want to use windows :D

This is my hardware lspci:

00:00.0 Host bridge: Intel Corporation Core Processor DRAM Controller

    (rev 02) 00:01.0 PCI bridge: Intel Corporation Core Processor PCI
    Express x16 Root Port (rev 02) 00:02.0 VGA compatible controller:
    Intel Corporation Core Processor Integrated Graphics Controller (rev
    02) 00:16.0 Communication controller: Intel Corporation 5 Series/3400 Series Chipset HECI Controller (rev 06) 00:1a.0 USB controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host
    Controller (rev 05) 00:1b.0 Audio device: Intel Corporation 5
    Series/3400 Series Chipset High Definition Audio (rev 05) 00:1c.0 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express
    Root Port 1 (rev 05) 00:1c.2 PCI bridge: Intel Corporation 5
    Series/3400 Series Chipset PCI Express Root Port 3 (rev 05) 00:1d.0
    USB controller: Intel Corporation 5 Series/3400 Series Chipset USB2
    Enhanced Host Controller (rev 05) 00:1e.0 PCI bridge: Intel
    Corporation 82801 Mobile PCI Bridge (rev a5) 00:1f.0 ISA bridge:
    Intel Corporation Mobile 5 Series Chipset LPC Interface Controller
    (rev 05) 00:1f.2 SATA controller: Intel Corporation 5 Series/3400
    Series Chipset 4 port SATA AHCI Controller (rev 05) 00:1f.3 SMBus:
    Intel Corporation 5 Series/3400 Series Chipset SMBus Controller (rev
    05) 00:1f.6 Signal processing controller: Intel Corporation 5
    Series/3400 Series Chipset Thermal Subsystem (rev 05) 01:00.0 VGA
    compatible controller: Advanced Micro Devices [AMD] nee ATI Manhattan [Mobility Radeon HD 5400 Series] 01:00.1 Audio device: Advanced Micro Devices [AMD] nee ATI Cedar HDMI Audio [Radeon HD 5400/6300 Series]
    02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd.
    RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 02)
    03:00.0 Network controller: Broadcom Corporation BCM4313 802.11b/g/n
    Wireless LAN Controller (rev 01) 7f:00.0 Host bridge: Intel
    Corporation Core Processor QuickPath Architecture Generic Non-core
    Registers (rev 02) 7f:00.1 Host bridge: Intel Corporation Core
    Processor QuickPath Architecture System Address Decoder (rev 02)
    7f:02.0 Host bridge: Intel Corporation Core Processor QPI Link 0 (rev 02) 7f:02.1 Host bridge: Intel Corporation Core Processor QPI
    Physical 0 (rev 02) 7f:02.2 Host bridge: Intel Corporation Core
    Processor Reserved (rev 02) 7f:02.3 Host bridge: Intel Corporation
    Core Processor Reserved (rev 02
share|improve this question
    
How did you install the fglrx driver? after doing a search it seems to affect people with on-board intel graphics. Is there an option in your bios to disable the on-board graphics. My card is a Radeon HD 5430 series and works without issue but I don't have on-board intel. –  Chris Carter Oct 15 '12 at 19:04

1 Answer 1

there is no solution, the ati 5400 is not supported, amd and intel haven t wrote good driver, i have the same notebook, you have too disable the ati card with acpi_call, and use the intel 3d see : http://linux-hybrid-graphics.blogspot.com.es/2010/07/using-acpicall-module-to-switch-onoff.html

and desactivate ati driver

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.