Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have been searching all day to no avail. I have just installed ubuntu 12.04 as dual boot on a dell optiplex 990, which has a Intel 82579LM NIC. I have it wired up via ethernet to my college network, and it says it is connected to the wired network, yet I have not internet and cannot ping anything. Below I have included some basic checks (pretty much the limit of my knowledge on this subject). It is worth noting that when running windows (it is dual booted) the internet works fine so NIC is fine and so is the ethernet cable itself. I have also downloaded the driver for the NIC from intel and installed on the machine in ubuntu (driver downloaded from here)

I have run the following commands: ifconfig:

aly@neon:~/Downloads/e1000e-2.1.4/src$ ifconfig
eth0      Link encap:Ethernet  HWaddr 90:b1:1c:5e:2a:06  
          inet6 addr: 2001:630:12:1082:92b1:1cff:fe5e:2a06/64 Scope:Global
          inet6 addr: 2001:630:12:1075:92b1:1cff:fe5e:2a06/64 Scope:Global
          inet6 addr: fe80::92b1:1cff:fe5e:2a06/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:6268 errors:0 dropped:0 overruns:0 frame:0
          TX packets:172 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:891800 (891.8 KB)  TX bytes:36150 (36.1 KB)
          Interrupt:20 Memory:e1500000-e1520000 

eth0:avahi Link encap:Ethernet  HWaddr 90:b1:1c:5e:2a:06  
          inet addr:169.254.3.202  Bcast:169.254.255.255  Mask:255.255.0.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Interrupt:20 Memory:e1500000-e1520000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:2152 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2152 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:137020 (137.0 KB)  TX bytes:137020 (137.0 KB)

lspci

 00:19.0 Ethernet controller: Intel Corporation 82579LM Gigabit Network Connection (rev 04)

ping 8.8.8.8

aly@neon:~/Downloads/e1000e-2.1.4/src$ ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
From 169.254.3.202 icmp_seq=1 Destination Host Unreachable
From 169.254.3.202 icmp_seq=2 Destination Host Unreachable
From 169.254.3.202 icmp_seq=5 Destination Host Unreachable
From 169.254.3.202 icmp_seq=6 Destination Host Unreachable
From 169.254.3.202 icmp_seq=7 Destination Host Unreachable
From 169.254.3.202 icmp_seq=8 Destination Host Unreachable

And here is a screenshot of the connection information (when connected to the wired network), it seems odd as there is no ipv4 addr

enter image description here

share|improve this question

closed as too localized by Bruno Pereira Jan 15 '13 at 15:57

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Hey Ali, is your problem still existant? If no, what have you done to get rid of it? –  qbi Jan 15 '13 at 13:47
    
@qbi Problem was fixed by sys admins, they just moved me onto a different network. I will close question as I doubt anyone will benefit from it –  Aly Jan 15 '13 at 14:01

2 Answers 2

I note:

SIOCSIFFLAGS: Cannot assign requested address

That suggests there are settings in /etc/network/interfaces that are interfering and conflicting with Network Manager. Please check:

    sudo gedit /etc/network/interfaces

The file should conatin nothing more than:

    auto lo
    iface lo inet loopback

Proofread, save and close gedit. Restart NM:

    sudo service network-manager restart

Now does it connect? If not, please check for any settings in Network Manager. For instance, if you've asked for a static address of 192.168.1.203 and the college network uses 192.168.55.0 etc., you won't connect. Remove any extra settings in NM.

share|improve this answer

Try running the following command:

sudo ifconfig eth0:avahi down

and then try connecting again.

share|improve this answer
    
gives me the error SIOCSIFFLAGS: Cannot assign requested address –  Aly Nov 1 '12 at 18:06
    
check your ifconfig output again and if there are more than one eth0 connections, turn off the second one using the above command. –  green7 Nov 1 '12 at 19:03
    
ifconfig shows just eth0 and lo –  Aly Nov 2 '12 at 9:54
    
it has now magically started working. It has done this once before but then just dies out again :s –  Aly Nov 2 '12 at 9:57
    
well, at any point of time you should have only one eth0, if it's the case the connection should work. –  green7 Nov 2 '12 at 9:59

Not the answer you're looking for? Browse other questions tagged or ask your own question.