Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

How should I use no machine in windows to remotely connect to ubuntu12.04? I got this:

Authentication failed.

Do I need to configure something in Ubuntu machine?

In Ubuntu machine, I chose 'sharing' in Remote Desktop Preferences.

Thank you in advance!

share|improve this question
add comment

2 Answers 2

Ubuntu's Desktop Sharing is just the VNC protocol under the hood, whereas Windows uses RDP. So you're either going to have to get Ubuntu running RDP. As @laurent mentioned, there's xrdp, but I haven't used it personally. The easier method is to use a VNC client on Windows, and there are a tonne of those that should all work, including:

There's also the NoMachine/NX stuff, but it's moderately complicated to get set up compared to VNC-based stuff.

share|improve this answer
add comment

In Ubuntu you need to install and configure at least nx server and nx node. Not sure if you need to install nx client too. You can download them from no machine website.

Another option is to install xrdppackage in ubuntu and to connect using the normal RDP connection software in Windows.

The sharing desktop option is to share to another Ubuntu desktop using the Ubuntu's Sharing Desktop Application.

share|improve this answer
    
I am trying to use xrdp to connect to the existing NX server, and it seems to connect OK, however, I have no status bar or no menu bar on the left. What would be my best solution on this ? –  jfmessier Nov 1 '12 at 15:14
    
xrdp should be the server on the ubuntu machine and you connect to it using a RDP client (native windows RDP or possibly something like Remmina on Linux) and you don't need to use NX on any of the machines. If you use NX (client and server), afaik there was a problem with the Unity interface and you have to configure nx client for that. I'll try to find the link of this answer and report here quickly –  laurent Nov 1 '12 at 16:40
    
Found it... NX client doesn't work with default config using Unity 3D so the link below shows how to fix that and a few other possibilities (running xfce or unity 2d - not sure this last one still works). superuser.com/questions/389992/…. Anyways I didn't try NX since some time as using xrdp and remmina (or windows native RDP client) is a lot easier and faster. –  laurent Nov 1 '12 at 17:13
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.