Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am in the process of updating a bunch of machines to 12.xx.

For regular package updates I tried apt-proxy, which had random hiccups (clients hanging on various headers). Now I installed apt-cacher-ng, but that seems not to work when running do-release-upgrade (I'm guessing because the special update-info does not match some URL pattern of apt-cacher-ng):

user@machine:~# sudo do-release-upgrade --proposed
Checking for a new ubuntu release
Failed Upgrade tool signature
Done Upgrade tool
Done downloading
authenticate 'lucid.tar.gz' against 'lucid.tar.gz.gpg'
exception from gpg: GnuPG exited non-zero, with code 131072
Debug information:


gpg: can't open `/tmp/tmpJCfO-a/lucid.tar.gz.gpg'
gpg: verify signatures failed: file open error

Authentication failed
Authenticating the upgrade failed. There may be a problem with the network or with the server.

Now I read about squid-deb-proxy and the dynamic broadcasting seems neat, especially since we have notebooks in our office.

Will that proxy work with do-release-upgrade or should I set up my own Squid altogether?

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

Yes, squid-deb-proxy works with do-release-upgrades, I recommend doing one machine first to "seed" the cache, then you should be good to go.

See also:

share|improve this answer
    
Thanks for your answer! I just tried it and according to the access.log the squid-deb-proxy is getting utilized during do-release-upgrade. Thanks! –  baccus Oct 16 '12 at 7:06
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.