Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I try to login to Ubuntu 10.10 I get a flickering screen for a second showing - Ubuntu 10.10 ............. and then I get a blank purple coloured screen[Ubuntu's theme colour] which doesn't progress any further

Can anybody suggest a remedy to this problem?

From whatever questions I searched in various Ubuntu Forums it seems like this problem is likely caused by a missing NVIDIA Display Driver[which is being used in my Sony Vaio Laptop] update in Ubuntu releases If that's the case then how can I update my NVIDIA Display Driver for Ubuntu 10.10 without being able to log into the Ubuntu 10.10?

share|improve this question

1 Answer 1

You press Ctrl + Alt + F1 and install newest nvidia driver using the following line:

sudo apt-get install nvidia-current

If you still can't login after restart, boot into recovery mode and run xfix:

alt text

login into machine, then go to drivers and activate the nvidia driver.

It's likely that you will have weird boot screen after using proprietary nvidia driver, you can repair it with THIS solution.

good luck.

share|improve this answer
    
Thanks danizmax I'll try out your solution coming weekend –  pritamn Jan 6 '11 at 4:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.